Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has been bothering me for about a week now,

I have been looking up answers on forums and everything and nothing seems to work. What happens is when i start minecraft i get this stacktrace:

org.lwjgl.LWJGLException: Could not init GLX
at org.lwjgl.opengl.LinuxDisplayPeerInfo.initDefaultPeerInfo(Native Method)
at org.lwjgl.opengl.LinuxDisplayPeerInfo.<init>(LinuxDisplayPeerInfo.java:61)
at org.lwjgl.opengl.LinuxDisplay.createPeerInfo(LinuxDisplay.java:788)
at org.lwjgl.opengl.DrawableGL.setPixelFormat(DrawableGL.java:61)
at org.lwjgl.opengl.Display.create(Display.java:846)
at org.lwjgl.opengl.Display.create(Display.java:757)
at org.lwjgl.opengl.Display.create(Display.java:739)
at avx.Q(SourceFile:303)
at avx.e(SourceFile:622)
at net.minecraft.client.main.Main.main(SourceFile:103)

This isn't a bug in minecraft, before i was able to run minecraft perfectly fine.

What i think happened is that i tried to update my ubuntu and got a graphics warning so i thought maybe i shouldn't and cancelled part way into updating, ever since i keep getting this error and nothing i have tried has worked.

I have tried updating drivers, installing VAAPI. and bumblebee just stopped my ubuntu from launching. I must have gone through hundreds of answers and threads.

When i run glxinfo i get this output:

name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
 Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

This may seem like a duplicate but nothing i have found has worked and im really stuck.

My graphics card: Intel HD Graphics 3000 and my processor is an Intel i3. and yes i do have oracle java.

Help is very much appreciated.

EDIT: Fixed O.o bumblebee decided to work this time... odd before it made my laptop unbootable.

share|improve this question
Wait, you canceled in the middle of an update? So now you may very well have a broken system, which would cause all sorts of problems... Did you receive a warning (what was it?) and then stop as soon as you got the warning? –  searchfgold6789 Sep 5 '13 at 21:39
Thats what i fear xD, something about my graphics card not being supported in the update, and i cancelled while it was updating the repo's etc. Now i kinda get quite a few system errors but my system as far as i can tell is perfectly fine except for OpenGL. And sometimes i write games in java but im kinda resisting a full reinstall because even if i keep my /Home i will lose a whole ton of stuff. –  tommycake50 Sep 5 '13 at 21:43
What version were you upgrading to? And which graphics card do you have? –  searchfgold6789 Sep 5 '13 at 21:44
I was upgrading to 12.10 from 12.04 LTS. My graphics card is Intel HD Graphics 3000 and on details my graphics info has disappeared but i think it said something like sandybridge. –  tommycake50 Sep 5 '13 at 21:46
Since you found a solution, would you do other people with the same problem a favor and post it as an answer to your own question? Glad to hear you got things working. –  searchfgold6789 Sep 9 '13 at 0:20
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.