Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I build a new system with a Core i5-4570S CPU and I use the internal graphics card.

I can Install Ubuntu 13.04 without problem and everything seems to work fine, but during boot and when I turn the PC off I see some really strange colors on the screen, kind of blue and the colors seem to be moving.

Do I have to worry about this? Once I am in the Unity/Gnome Desktop this does not occur.

The card seem to be recognised:

00:02.0 VGA compatible controller: Intel Corporation Haswell Integrated Graphics Controller (rev 06)

I Am using this kernel:

3.8.0-30-generic #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

The second problem just came up. I did and update today, there was a new kernel. After this update the machine does not show the lightdm login screen, just a blinking cursor. When I do CTRL+ALT+F2 and restart the lightdm it gives me the login screen.

what can I do? Do you need more info?

share|improve this question
add comment

2 Answers 2

It seems to be your graphics card problem. The graphics card driver doesn't match with your newest kernel. Give it a try first, if it doesn't work then I will suggest you to install latest graphics card driver:

Try to reconfigure lightdm, it may fix your issue

  • When blank screen appears the pressCTRL+ALT+F1 to go to tty1, login and execute following commands:

    sudo dpkg-reconfigre lightdm
    
  • Then chose lightdm from the list.

  • Restart your system:

    sudo reboot now
    

It may fix your issue. If doesn't fix then follow 2nd Method.

Method 2:

Installing a new display manager can fix your problem. Steps to install GDM(a display manager much like lightdm):

  • Again when black screen appears CTRL+ALT+F1 then login and execute following commands:

    sudo apt-get install gdm
    sudo dpkg-reconfigure lightdm
    

    then chose gdm from the list. And restart your system:

    sudo reboot now
    

Installing/Updating Latest graphics driver for Intel

  • Open a terminal and execute following commands:

    sudo apt-get install intel-linux-graphics-installer
    

    if it says something: package not found then go to Update section below and execute this command again.

  • Once installed open it from dash and follow on screen instruction to update your graphics driver.
  • Thats all. It would update/install your graphics driver to a newer version.

Update:

Run these commands to get latest version of Intel-Linux-Graphics-Installer

    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg -O - | \

    sudo apt-key add -


    wget --no-check-certificate https://download.01.org/gfx/RPM-GPG-KEY-ilg-2 -O - | \

    sudo apt-key add -

    sudo apt-get update

Hope these methods solve your issue. Reply for further assistance.

share|improve this answer
    
Hello, that did fix the loginscreen problem. big thnx How can I update the graphicscard driver? Do I have to install a new kernel, what is the safest way to get a new kernel? greetings –  Rupertt Sep 5 '13 at 18:44
    
Sounds good.. Since you are using Ubuntu 13.04 you can use Intel-Linux-Graphics-Installer a software from Intel which updates your Intel Graphics Driver very easily. I am editing my answer and describing how can you install.. Once it solves your issue, just mark my answer as solved so that it would help others to find their solution. –  Saurav Kumar Sep 5 '13 at 18:50
    
check for my answer.. Reply if something goes wrong. –  Saurav Kumar Sep 5 '13 at 19:02
    
Hello, i got a bit experimental and just downloaded the latest version from 01.org because i couldnt find that pacakge. It seems to work fine, i have to do a second reboot. do I have to add a extra repo for this package? I still have these strange graphics while reboot/shutdown :(. –  Rupertt Sep 5 '13 at 19:08
    
I didn't get you? What did you download Intel-Linux-Graphics-Installer .deb file? Did you follow my steps precisely? Did you follow the steps in Update section? –  Saurav Kumar Sep 5 '13 at 19:12
show 19 more comments

Last Option that you can give a try

  • Open terminal(CTRL+ALT+T) and execute these commands:

    sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.back
    

    if this command says file not available then not a problem. Proceed further..

    sudo gedit /etc/X11/xorg.conf
    

    when editor opens copy following code and paste on the editor:

    Section "Device"
    Identifier "Configured Video Device"
    Driver "intel"
    EndSection
    
    Section "Monitor"
    Identifier "Configured Monitor"
    EndSection
    
    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    EndSection
    

    Save(CTRL+S) and close(CTRL+Q) and execute following:

    sudo dpkg-reconfigure $(dpkg -l | awk '{print $2}'|grep "^xserver"|tr '\n' ' ')
    
    sudo update-initramfs -u
    
  • Then finally restart your computer.

    sudo reboot
    

Hope this last option works for you.. If you get any time of error, just remove /etc/X11/xorg.conf file and restart your system again.

share|improve this answer
    
sorry, still the same. would a kernel update help, maybe? is it safe to do this? ubuntuhandbook.org/index.php/2013/07/… –  Rupertt Sep 6 '13 at 6:19
    
Did you get any error at any stage of the procedure? –  Saurav Kumar Sep 6 '13 at 6:20
    
no i did not see any errors –  Rupertt Sep 6 '13 at 6:21
    
Yes, you can any new kernel you want.. Read My Post for more information of Kernel Update. –  Saurav Kumar Sep 6 '13 at 6:22
    
k, i try that after work. can I just use the latest version? kernel.ubuntu.com/~kernel-ppa/mainline/daily/current –  Rupertt Sep 6 '13 at 6:26
show 11 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.