Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update manger won't open saying

E: could not open file/var/lib/dpkg/status - open(2: No such file or directory),
E:the package lists or status file could not be parsed or opened.

what to do?

share|improve this question
What did you do before this happened? It should not occur on it's own, and this could be a pretty serious issue (not sure how you would go about fixing it). – RolandiXor Apr 9 '11 at 5:27
Have you solved this issue? – pl1nk Jun 24 '12 at 22:16

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

And then try to update.

share|improve this answer

Just had the same problem tried

sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status

it could not find the file opened nautilus and the whole var/lib directory was missing rebooted server and problem it fixed its-self - Time for a backup of everything and then maybe replace a few disks.

share|improve this answer

Looks like this one, anyway, I have yet to try it. Will get back to you.

share|improve this answer

I had the same problem. I couldn't do ANYTHING involving the apt command or update manager, so I couldn't even get the tools that people recommeded I'd use to fix the problem.

I navigated to cd/var/lib/dpkg and found that it only contained 2 files: labels and lock. No status or anything.

So I just created a status file using

touch /var/lib/dpkg/status

and then I could use apt-get again. I did clean, purge, update and all that but it didn't help. Dpkg was useless. Seems like this can occur quite often, for instace if you shutdown during an update. I had to recover dpkg from scratch

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.