Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've checked some similar answers which suggest holding "shift" until the screen shows up, this does not work for me. I also tried restarting the system several times in a row and even powering off during the boot sequence, since grub is supposed to detect failures and show the boot screen after such an event, no luck...

I got into this mess because of changing my graphic card configuration and now the system will not even show the Ubuntu log in screen. I know the grub boot menu is intact because immediately after the system failed to boot the first time, I restarted saw the menu and decided, to try to boot normally once more... When in hind sight I would be fine if I'd only chosen to start in safe graphics mode.

I've booted the system with a 10.10 installation disk and can get to any files but grub2 now required editing /etc/default/grub and then sudo update-grub but since I'm running from CD/DVD I this isn't going to work right...

Edit: I don't yet understand the answer provided by psusi. If I say

sudo chroot /media/661ae4bd-7dde-42c9-b944-f75cebeaa1ad 
sudo update-grub

I get

/usr/lib/grub/grub-mkconfig_lib: 38: cannot create /dev/null: Permission denied
/usr/sbin/grub-probe: error: cannot find a device for / (is /dev mounted?).
share|improve this question
up vote 3 down vote accepted

To show the Grub 2 menu at boot time it is only the right hand shift key that works

share|improve this answer
I thought I tried both, but I think something funny happens if I hold down shift during the initial bios screen... not sure but holding down both shift keys after the initial boot screen passed worked... – Quaternion Apr 8 '11 at 21:03

When you mount the disk from the live cd, you can run update-grub with chroot. Assuming you mounted the hard disk in /mnt:

for f in sys proc dev ; do sudo mount --bind /$f /mnt/$f ; done
sudo chroot /mnt
for f in sys proc dev ; do sudo umount /mnt/$f ; done
share|improve this answer
Ok when I boot there is 480GB filesystem under "Places" selecting this causes the following mount /media/661ae4bd-7dde-42c9-b944-f75cebeaa1ad but using that value does not work. I'll edit my question because formatting is easer and show the result. – Quaternion Apr 8 '11 at 20:04
@Quanternion you forgot the for loop to bind mount /dev, /sys, and /proc into the chroot. – psusi Apr 9 '11 at 3:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.