Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Maverick Meerkat, and I have a Aliph Jawbone ERA for VoIP communications. I am using it to stream Pandora for some musical goodness while I work, and the sound quality is just awful. Is there a way to select/change/update the audio codec used to stream the signal to the headset for better sound quality?

Thanks in advance

share|improve this question
up vote 1 down vote accepted

For high quality streaming the codec used needs to be set to A2DP. This can be done in pulseaudio audio settings by choosing the appropriate (A2DP) profile in the Hardware tab.

If your sound quality is still poor then unfortunately the SBC codec (that is included as a fallback for low bandwith in the A2DP profile) may be used. You may want to test if in your individual settings this is improved when running the most recent Bluez package (however you would need to compile this from source). Some debugging of the A2DP codec has been done there recently.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.