Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new to Linux. I installed Ubuntu for the first time on a pre-installed Windows 8 Dell Inspiron PC by creating a partition (volume shrink through Windows Computer Management). I created three partitions: a boot, a root and a swap. I followed the instructions for a UEFI system and everything went fine. However, I later installed Grub as well in order to be able to choose between the two operating systems during startup. The first time I rebooted, Grub functioned properly. However, afterwards not only did it not work anymore, but also the Windows boot loader cannot detect either operating system anymore. When I boot, a Media Check appears and it fails twice. Then I get a message saying 'No bootable device'. I do not have a Windows 8 CD so I am trying to fix the problem through the Ubuntu live USB. Since both OS's are where they should be (I know by checking the GPT partition table through 'parted' and running a bootinfo script), it seems to be the case that Grub has messed up the Windows boot files (by overwriting them on the EFI boot partition). How can I restore the Windows boot loader without the installation CD of Windows 8? I have read a lot of similar threads online but have found no effective solution without using the Windows 8 CD. Could anybody help please? Thanks.

share|improve this question
    
I have tried using boot-repair several times but it doesn't work. The last time I tried to just restore the EFI backup files and I received this url: paste.ubuntu.com/6064341 –  konsakel Sep 4 '13 at 22:21
    
Could you add that link in the question itself? Also, why you didn't run recommended repair? –  Braiam Sep 5 '13 at 0:32
    
@Braiam: I performed the recommended repair initially (and several times afterwards) and only later did I try just restoring the EFI backups but neither approach worked. –  konsakel Sep 9 '13 at 12:29
add comment

3 Answers 3

Your sda1 has to have to boot flag to make it the ESP or efi partition. You can use gparted and choose manage flags.

But your Windows looks like it is missing the system reserved partition. Did you delete that?

Order on drive is important:

http://en.wikipedia.org/wiki/Microsoft_Reserved_Partition

Microsoft suggested partitions including reserved partition for gpt & UEFI:

http://technet.microsoft.com/en-us/library/dd744301%28WS.10%29.aspx

Only minor changes to fix Windows can be done from Linux. You really need Windows tools to fix Windows issues. Did you not turn off fast boot? And you may need chkdsk. Some third party Windows partition tools or EasyBCD may have repair functions. EasyBCD not really recommended with UEFI booting otherwise.

share|improve this answer
    
I haven't deleted any partitions, everything is there including WinRE tools, PBR image (which is the recovery partition if not mistaken? don't know how to access that..), DIAG tools etc. –  konsakel Sep 9 '13 at 12:30
add comment

Thanks a lot for your replies guys.

I have tried a couple of things with some friends and manage to read ubuntu (by re-installing and not using boot-repair which I think messed things up in the first place, either that or Grub itself). I now created a windows 8 bootable Dvd and will try to fix the MBR so that it points to Windows.

Thanks for all the help, I'll write an update if it works (and hopefully it should judging by many other forums regarding fixing the MBR using the installation disk of Windows 8).

share|improve this answer
add comment

Solution: The only working solution I managed to find with such boot problems (i.e. Windows not being detected by boot loader as an option) is through the installation disk as @oldfred suggested. It seems that you have to perform Automatic Repair up to 3 times (it only worked the third time for me) or use the commands: bootrec.exe/FixMbr bootrec.exe/FixBoot in the command prompt under Advanced Options (although didn't work for me the first 2 times)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.