Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm running kubuntu 13.04 , this issue started recently, not sure exactly when though, and seems strange. the digital clock in the panel sets itself ahead 4 hours, each reboot after resetting, it sets itself ahead again. i went through suggestions, others have with the same problem, from different forums. if i remove the digital clock from the panel and add a desktop digital clock widget,set the time and timezone, on each reboot it keeps correct time, if i add a digital clock to the panel ,it starts to jump the time forwards on each reboot. any ideas as to why the desktop clock would work correctly and the panel clock not?

share|improve this question
add comment

2 Answers 2

Source: http://ubuntuforums.org/archive/index.php/t-836480.html

On the Ubuntu Forums thread I have linked, there is a post that says to edit /etc/default/rcS and find a line that says utc=yes and change that to utc=no.

From then on, this issue shouldn't happen again.

share|improve this answer
    
I saw the same thread about a day or so ago,i edited the line, changed the panel digital clock, rebooted and the clock did the same thing.I checked /etc/default/rcS to see if anything changed it and it was still marked "no".Another weird thing is i run windows XP in Virtualbox, with the panel clock running the time is off in XP also,i adjusted the time in XP,it doesn't take at all.If i remove the panel clock, set the time and timezone on the desktop clock, xp clock works.If the panel and digital clock widgets are the same, then i suspect something with the panel.New panels won't work either –  james stcyr Sep 4 '13 at 23:14
    
maybe fixed,possible solution was because i tried only two things and i wasn't paying attention to the sequence, was to use sudo dpkg-reconfigure tzdata then set the time going thru system settings, or vice versa. if i use kde control panel to set time,it messes up. if i right click on the clock and set time ,it messes up. but so far after a few reboots it's staying correct. so i suggest using the system settings from application menu. –  james stcyr Sep 6 '13 at 0:09
add comment

You can sync the system clock by using htpdate and this guide (originally for Gentoo). You can install Ubuntu packages from the htpdate PPA (release). Be careful to finalize synchronization via hwclock --systohc and hwclock --show.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.