Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have used pygame on my computer many times before but all of the sudden i get an error when trying to import it. The problem may have started when i installed VisualBoyAdvance.

The error says:

Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/pygame/__init__.py", line 99, in <module>
    from pygame.base import *
ImportError: /usr/local/lib/libSDL-1.2.so.0: undefined symbol: _XGetRequest
share|improve this question
    
How did you install VisualBoyAdvenced?. Did you compile something?. Is your system updated? –  Javier Rivera Sep 5 '13 at 17:19
    
i tried multiple ways of vba i probably tried both terminal and ubuntu software center, sorry it was a couple weeks ago, what do you mean by updated? –  Kevin Klute Sep 5 '13 at 22:56
    
This problem is likely a library miss-match. If you compiled vba and some of its dependencies that could explain it. By updated I mean that the system is up to date, that all the packages are at the most current version available in the repos, a partial update could also cause this problem. –  Javier Rivera Sep 6 '13 at 8:02
    
software updater said all software is up to date, I asked on stack overflow, they said I have a mismatch between libx11 and sdl, but nobody had any advice on how to fix it. –  Kevin Klute Sep 6 '13 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.