Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem

I am trying to run an OpenGL application which has worked on previous releases of Ubuntu on other machines but which happily opens windows crashes when I try and draw anything in them.

System

  • Ubuntu

    64 bit Release: 13.04

  • CPU

    processor   : 2
    vendor_id   : AuthenticAMD
    cpu family  : 16
    model       : 4
    model name  : AMD Phenom(tm) II X4 B95 Processor
    stepping    : 2
    microcode   : 0x10000db
    cpu MHz     : 800.000
    cache size  : 512 KB
    physical id : 0
    siblings    : 4
    core id     : 2
    cpu cores   : 4
    apicid      : 2
    initial apicid  : 2
    fpu     : yes
    fpu_exception   : yes
    cpuid level : 5
    wp      : yes
    
  • Graphics

    01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4200]

Troubleshooting

  1. I downloaded globs and ran all the standard tests. They all worked properly except for GLSL_paralax which failed to even start.

  2. I checked my graphics driver.

    glxinfo | grep render
    direct rendering: Yes
    OpenGL renderer string: Gallium 0.4 on AMD RS880
    GL_NV_conditional_render, GL_AMD_conservative_depth, 
    

    I understand this to mean that I am using the open source graphics driver and I am not using software rendering.

  3. I ran glxgears

    glxgears -info
    Running synchronized to the vertical refresh.  The framerate should be
    approximately the same as the monitor refresh rate.
    
    GL_RENDERER   = Gallium 0.4 on AMD RS880
    GL_VERSION    = 3.0 Mesa 9.1.3
    GL_VENDOR     = X.Org
    
    ...
    
    301 frames in 5.0 seconds = 60.155 FPS
    299 frames in 5.0 seconds = 59.766 FPS
    298 frames in 5.0 seconds = 59.566 FPS
    300 frames in 5.0 seconds = 59.968 FPS
    

    I think this is a bad result. Other sources said that I should have a much higher framerate, though my monitor is set at 60 Hz so if the render rate is set at that, it seems correct

  4. I checked the OpenGL error log

     cat /var/log/Xorg.0.log | grep EE
     (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
     [    14.665] Initializing built-in extension MIT-SCREEN-SAVER
     [    14.797] (EE) Failed to load module "fglrx" (module does not exist, 0)
     [    14.832] (EE) Failed to load module "fglrx" (module does not exist, 0)
    

    I think this means that I do not have the fglrx installed

  5. I looked up what fglrx is and it appears that it is part of the proprietary OpenGL driver. Instructions on how to install it are found here: http://wiki.cchtml.com/index.php/Ubuntu_Raring_Installation_Guide#Installing_Proprietary_Drivers_a.k.a._Catalyst.2Ffglrx

Questions

  1. Does anyone have any insight as to why the GLSL_paralax test failed to even start? Is there another comparable test I could try?

  2. Are there other diagnostic tests I could perform to isolate my problems?

  3. Is the missing fglrx module important? Could it be the source of my problems?

  4. If so, can I get it without installing the proprietary driver?

  5. If I need the proprietary driver, is the link I included the safest/easiest way to get it? I am loath to follow their instructions as I have had problems manually configuring the graphics driver of other Linux machines. Is there a graphical tool like Additional Drivers which could be used instead?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I solved my problem however, the solution was that there was an unusual error in the openGL code I was running. It failed because it could not find the required fonts not because of graphical issues. Because of the way the c-based OGL and font calls were embedded into python code, this was difficult to track down.

In the process of discovering this I tried several things including upgrading to the proprietary graphics drivers. I would Not recommend this for anyone running an ATI HD graphics card which is not supported by the 13.04+ release of fglrx. You need to downgrade your Xserver and this makes unity run poorly. The proprietary drivers do not add much i could see to the system graphics, though many reported that they have advantages for laptops in terms of power consumption.

Finally, the GLSL_paralax test from globs failed for non driver-related reasons.

Overall, all graphics work on my system with the open source drivers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.