Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In gnome, whenever I click on a contextual menu item (eg. right click on a window in the task bar) and then hover over a sub-item (eg. Move to another workspace) that is expandable, the submenu is not shown.

In order to show the submenu, I have to click about 4 times with my left mouse button OR leave the item again and re-hover the item with my mouse.

Why does the submenu item not expand automatically on the initial mouse-over (hover)?

Update: this is a pretty fresh install without any special interface software, just the default gnome installation. Ubuntu 10.10 with latest updates.

Also, this problem has been here since I installed Ubuntu a couple of months ago (the reason it is still a fresh install is because I rarely use Ubuntu, because of bugs like these).

Update: My visual effects were on "normal". I then set them to "none", and now this issue has been resolved.

share|improve this question
    
I have a similar problem with right click menus and Notification Area menus. What graphics hardware and driver are you using? Are you using compiz (aka normal or extra "visual effects")? I've always had a suspicion the nvidia driver has something to do with it. –  Oli Apr 12 '11 at 10:26
    
I've got a ATI Mobility Radeon HD 5470 video card, thus no nvidia. –  Tom Apr 12 '11 at 10:37
    
It appears that the clearlook theme is the main suspect here. –  Tom Apr 13 '11 at 8:12
    
Good to know that. –  desgua Apr 13 '11 at 11:00
add comment

1 Answer

up vote 4 down vote accepted
+300
  1. This could depend on your chosen theme. I've read a while ago, that someone had the same problems with the clearlooks-engine. He had chosen another theme and the problems were gone.

  2. You can try to disable "Mouse Position Polling" in compiz.

Install CompizConfig Settings Manager:

sudo aptitude install compizconfig-settings-manager

Then goto System/Preferences an chose "Advanced Desktop Effects Settings" (i'm not sure if it is still called this way, because i use ubuntu in german) and disable Mouse Position Polling:

enter image description here

share|improve this answer
    
changing the theme to ambiance from clearlooks fixed it! It looks like there is a bug with the clearlooks theme. –  Tom Apr 13 '11 at 8:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.