Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 13.04. The system is new, just installed.

I want to install package zeromq3 from PPA https://launchpad.net/~chris-lea/+archive/zeromq?field.series_filter=raring.

I do:

sudo add-apt-repository ppa:chris-lea/zeromq
sudo apt-get update

No problems, no errors.

Checking the repository was added:

cat /etc/apt/sources.list.d/chris-lea-zeromq-raring.list 

deb http://ppa.launchpad.net/chris-lea/zeromq/ubuntu raring main

# deb-src http://ppa.launchpad.net/chris-lea/zeromq/ubuntu raring main

Checking the key was added:

sudo apt-key list

... lot of lines...

pub 1024R/C7917B12 2010-05-17

uid Launchpad chrislea

The key is correct, the same which is on the PPA page. The repo was added to sources. Looks good!

Trying to install:

apt-cache search zeromq3

This command returns nothing.

I was trying in Virtualbox and on real machine. I ran sudo apt-get clean and sudo apt-get autoclean. I also tried another PPA from Launchapd but that does not work either.

What's wrong? Why can't the package be found?

share|improve this question
2  
If you run grep ^Package: /var/lib/apt/lists/ppa.launchpad.net_chris*_Packages, you'll notice that zeromq3 is not in the packages from this ppa. Not sure what this means though. Maybe contact the ppa maintainer? –  Alaa Ali Sep 4 '13 at 9:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.