Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, so this is driving me nuts. I had to hard reboot my machine and now I have superblock issues on my boot disk. I have a Lenovo u310, which comes with two drives, a little ssd, and another 500GB. I installed Ubuntu on the ssd and put my home on the 500gb. From everything I can see, the big drive is fine (thank god), but the ssd is having superblock/journaling issues. When I reboot and try to run from the ssd, it gets through grub then throws an error along the line of "error: failed to write to sector 0x0938e9.

I'm currently running off a live usb, and I've looked around and found what I could but nothing seems to work. I've tried going through the process of updating the superblock from a backup from here. But each one of the backups I try says the same thing:

e2fsck 1.42 (29-Nov-2011)
e2fsck: Bad magic number in super-block while trying to open /dev/sda1

The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>

I almost tried running mke2fs -S -B 4096 /dev/sda1, but it sounds like I should save that for the very end.

I'm not trying to retrieve the data from this drive. I just want to do a clean install of Ubuntu but I can't because of these errors. Is there some way to just wipe it all away and start fresh? Everything I've found for wiping superblocks is mdadm raid stuff.

*EDIT Here's the output from sudo fdisk -l

Disk /dev/sda: 24.0 GB, 24015495168 bytes
255 heads, 63 sectors/track, 2919 cylinders, total 46905264 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf6f8853b

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1    46905263    23452631+  ee  GPT

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x0004005f

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1            2048   976773119   488385536   83  Linux

/dev/sda is the problematic ssd, and /dev/sdb is the one with all my (clean) data.

Update Just tried clearing the inode, from here. However, it can't open the file system:

sudo debugfs -w /dev/sda
debugfs 1.42 (29-Nov-2011)
/dev/sda: Bad magic number in super-block while opening filesystem
share|improve this question
    
Can you post the output of sudo fdisk -l? –  Mitch Sep 4 '13 at 7:00

1 Answer 1

up vote 1 down vote accepted

I think the drive is just fried. Luckily I had my home on a different drive, so I pulled out the dead one, and reinstalled on the good one. Wish I could've saved the ssd though.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.