Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu Minimal 12.04 LTS from USB. Everything was OK. But, when I try to install Grub into /dev/sda, the installation stops with a "fatal error".

So, I just entered /dev/sdb (just tried), Grub got installed without any problem in /dev/sdb.

Then, the installation finished without any problem. But after restart, it says 'grub rescue'.

I had only 1 hard drive. So what is sdb? I thought, USB drive was sda, and my hard drive sdb. Is it possible?

How can I fix it?

UPDATE 1 I tried Boot Repair, but it didn't work out. Here is my Boot Info Summary by "Boot Repair". https://gist.github.com/anonymous/6433404

share|improve this question
add comment

2 Answers

So what is sdb?

I'm afraid that you installed GRUB in your USB.

I thought, USB drive was sda, and my hard drive sdb. Is it possible?

Not always. You had to check first using fdisk -l.

How can I fix it?

With the little information you supplied, I'm afraid that your disk (or just the MBR) is badly damaged. Normally, the GRUB installation are flawless, unless you:

  1. Haven't shutdown Windows or any other installed OS.
  2. Have a dirty NTFS partition.
  3. The disk MBR is damaged.

I recommend you to get a Live system (instead the minimal) and try to repair your GRUB using boot-repair.

share|improve this answer
    
@Braiaim Thank you for replying. I tried boot-repair. First, I run Recommended repair. I didn't work out. After that, I selected Advanced Options. Then, I checked "Purge GRUB before reinstall it" and "ATA Disk Support"(because it says "solves the [out of disk] error"). But it didn't help me. Still got "out of disk" error, and "no device connected". I have Boot Info Summary. Can you inspect it for me? gist.github.com/anonymous/6433404 Thanks –  Robert 3000 Sep 4 '13 at 6:39
    
@Robert3000 Can you take an image of this "out of disk"? Also, did you reconfigured the BIOS to boot from disk again? –  Braiam Sep 4 '13 at 11:54
add comment

I would recommend you to run a live cd of ubuntu and install boot-repair. Open the terminal and copy and paste the following command:

sudo add-apt-repository -y ppa:yannubuntu/boot-repair && sudo apt-get update

After successfully adding and updating the repository type the following command:

sudo apt-get install -y boot-repair && boot-repair

There you can solve your issues related to boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.