Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently downloaded Lubuntu Server on my Apple Powerbook G4. I am unable to install anything on using both ethernet and wireless. I used sudo ethtool eth0 and it was there was a connection. I uninstalled and reinstalled Lubuntu multiple times and I am getting the same issue. I am receiving an error on log in enter image description here

When I go to compile a cpp file via vim and g++ i am getting this error:

enter image description here

When I go to install g++ this comes up:

enter image description here

Then I tried installing build-essentials i receive this: enter image description here

After that I tried to update and received this:

enter image description here

share|improve this question
    
I'm retagging your question because you have superfluous unnecessary tags. However, it looks like your DNS is broken or something, because your errors (which by the way you're cutting off in your pictures) suggest a failure to resolve ports.ubuntu.com and archive.ubuntu.com. If your computer isn't connected you can't download anything, either, and will have to load your packages from an external disk after manually downloading all the packages. However, your system might not have drivers for that, so you might have to download from a separate system to a USB drive or something. –  Thomas W. Sep 3 '13 at 21:06

1 Answer 1

Your installation errors are probably because, as Thomas W. notes, there is no connection. Do you have an ethernet cable attached? Is there an ethernet interface eth0?

ifconfig

Have you told the system to connect eth0?

sudo ifconfig eth0 up
sudo dhclient eth0

If you get an IP address, then you may install, download, etc. Your b43 errors are related to wireless. If you want to correct them, while you have an ethernet connection:

sudo apt-get install linux-firmware-nonfree

'Lubuntu' implies you have a desktop environment and Network Manager; your screenshots imply not. I will assume no Network Manager in my answer. To make persistent automatic connections, we'll need to amend a file, so install the text editor vim also:

sudo apt-get install vim

Then tell us if you want a persistent wired or wireless connection and we'll proceed.

share|improve this answer
    
This occurred both via wireless and ethernet. I did the following commands with both: ifconfig and sudo ifconfig eth0 up. But it still would not work. I still yet to try sudo dhcleint eth0. I would like to have a wireless connection, but I am always moving in location with secured connections that require username and log in (University Campus). How would I go about to connecting to that network? –  octain Sep 4 '13 at 14:23
    
Let's methodically take one step at a time. Do you have an ethernet interface? Learn from the terminal: ifconfig If so, does it report UP? If so, proceed to: sudo dhclient eth0 Did you get an IP address? –  chili555 Sep 4 '13 at 15:06
    
when I run ifconfig it gives me all the information such as link encap, inet addr, ect... when I run dhclient I get this : RTNETLINK answers: File exists –  octain Sep 6 '13 at 0:08
    
Is that all? Does it simply stop there? Or does it try to get an IP address and time out? –  chili555 Sep 6 '13 at 0:14
    
that is all that shows up, this is using an Ethernet cable via the home modem –  octain Sep 6 '13 at 1:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.