Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've recently installed a fresh version of Ubuntu 12.04.3 Desktop. At login screen, everything is black except for my mouse cursor and blinking underscore at top left. I can hear the Ubuntu startup drum sound and can enter desktop by simply entering my password.

I've noticed this starts happening after about the 4th or 5th reboot after install.

$ awk '/CRITICAL/ || /WARNING/' /var/log/lightdm/x-0-greeter.log

** (at-spi2-registryd:2210): WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
** (at-spi2-registryd:2210): WARNING **: Unable to register client with session manager
[+0.14s] CRITICAL: g_error_free: assertion `error != NULL' failed
[+0.17s] WARNING: IndicatorObject class does not have an accessible description.
[+0.21s] WARNING: IndicatorObject class does not have an accessible description.
[+0.56s] WARNING: invalid cast from `GtkMenuItem' to `IndicatorMenuItem'
[+0.56s] WARNING: invalid cast from `GtkMenuItem' to `IndicatorMenuItem'
[+0.56s] WARNING: invalid cast from `GtkMenuItem' to `IndicatorMenuItem'
[+0.56s] WARNING: menubar.vala:561: Indicator object 0x83bde8 not in menubar
[+0.56s] WARNING: Getting layout failed: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface `com.canonical.dbusmenu' on object at path /com/canonical/indicator/users/menu
[+0.80s] CRITICAL: ido_calendar_menu_item_set_date: assertion `IDO_IS_CALENDAR_MENU_ITEM(menuitem)' failed

I'm having trouble understanding these errors.

My graphics card is Intel HD 4600 integrated with Haswell CPU.

$ sudo lightdm --test-mode
Failed to use bus name org.freedesktop.DisplayManager, do you have appropriate permissions?

Upon looking at /etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf I see:

<!-- Only root can own the service -->
<policy user="root">
  <allow own="org.freedesktop.DisplayManager"/>
  <allow send_destination="org.freedesktop.DisplayManager" send_interface="org.freedesktop.DisplayManager" send_member="AddSeat"/>
</policy>

What's happening here? Root owns the service, yet I am asked if I have appropriate permissions when accessing as root.

share|improve this question

1 Answer 1

apt-get purge nvidia-prime

that solved the problem for me. Then I registered bumblebee ppa and manually install bumblebee instead.

share|improve this answer
    
If you read the post, you'll see I do not have an NVIDIA graphics card. –  John B Sep 17 '13 at 1:37
    
This solved my case, where I don't have NVIDIA card either on Trusty with Thinkpad t440s. –  IsaacS Apr 29 at 9:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.