Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to compile Unity 5.20, I get this error:

dh_shlibdeps
dpkg-shlibdeps: warning: Can't extract name and version from library name `libcompiztoolbox.so'
dpkg-shlibdeps: warning: Can't extract name and version from library name `libcompiztoolbox.so'
dpkg-shlibdeps: warning: Can't extract name and version from library name `libcomposite.so'
dpkg-shlibdeps: warning: Can't extract name and version from library name `libcomposite.so'
dpkg-shlibdeps: error: no dependency information found for /usr/lib/nvidia-319/libGL.so.1 (used by debian/unity/usr/lib/compiz/libunityshell.so).
dh_shlibdeps: dpkg-shlibdeps -Tdebian/unity.substvars debian/unity/usr/lib/compiz/libunitymtgrabhandles.so debian/unity/usr/lib/compiz/libunityshell.so debian/unity/usr/lib/compiz/libgtkloader.so returned exit code 2
make: *** [binary] Error 2
dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 2

I believe all dependencies are met, do you have any idea what could have caused this error?

I'm running Ubuntu 12.04 amd64. The process I used was:

sudo apt-get build-dep unity
apt-get source unity
dpkg-buildpackage -us -uc -nc

Thank you in advance!

share|improve this question
    
I took would like an answer to this! –  user1179330 Mar 10 at 5:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.