Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am helping a colleague who i having trouble installing ubuntu 10.10. He downloaded the ISO and installed into his memory stick. It works fine when he boots from the memory stick and uses it in live mode.

But whenever he installs it, at the end of installation (and on subsequent restarts) all he gets is a terminal. The terminal is quite usable, and he can work in terminal mode fine, but after a while even the terminal is lost and the screen goes completely blank.

We've tried installing it several times, but it always ends up this way. Can someone point out what is going wrong?

Edit:

His machine is a Intel Core-2 Duo with a Foxconn motherboard with integrated graphics (Intel Ironlake chipset AFAIK).

share|improve this question
    
Could you tell us more about the hardware you are using, especially the graphics card. Try sudo start gdm or sudo service gdm start during your terminal session and see what happens. –  sagarchalise Apr 8 '11 at 11:46
    
It's good idea to give some info on the hardware of the machine you're trying to install. –  nejode Apr 8 '11 at 11:50
    
@sagarchalise and @nejode: I have updated my question. I will try the commands suggested by sagarchalise and let you know. –  MAK Apr 8 '11 at 12:00
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding more detail? askubuntu.com/questions/14008/… –  Jorge Castro Apr 8 '11 at 14:51
    
What do you mean "the terminal is lost"? Can you switch to another terminal with alt-F2? Does the caps lock key toggle the LED? Can you still enter a command ( like sudo shutdown -h now ) and have it work, even though you can't see it? –  psusi Apr 8 '11 at 15:34

1 Answer 1

Maybe the graphical environment is disabled.

Try:

startx

or when needed:

sudo startx

If this is the problem, you may need to proper configure your graphical environment settings to run at the very startup.

Another idea that comes to my mind is that your machine is probably stuck in the wrong virtual desktop. Try with the [Alt][F7] keys combo (or a different one) in order to search for the graphical environment, which may be already started but not shown.

This happened to me a couple of times, and was self-solved after updating.

Good luck.

share|improve this answer
    
Thank you. I had already tried alt+function keys and none of them worked. Since this is a machine where I work and the weekend has already started, I will have to wait until Monday to try startx. I'll let you know how that goes. –  MAK Apr 8 '11 at 19:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.