Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i'm on ubuntustudio and i want to format my hd and try kubuntu (install in my acer notebook, no partion, no double operating system problem, only istall it) i've downloaded iso file ( kubuntu-10.10-desktop-i386.iso ), insert usb pen drive, then: system > administration > startup disk creator erased usb pen content, and "make startup disk" finally, reboot computer with pen inside usb port

normal boot didn't start (as expected) but only black screen with this signal:

SYSLINUX 4.03 2010-10-22 EDD Copyright (c) 1994-2010, H. Peter Anvin et al
unknown keyword in configuration file
boot:

i've tried different usb pen stick and different iso files (ubuntu, kubuntu, netbook edition).. always same problem (sometimes only the first line without "unknow keyword in conf file" error)

some advice?? sorry for my bad english

share|improve this question

5 Answers 5

up vote 4 down vote accepted

In 10.10 there is a bug in usb-creator that may cause your problems. Try creating your stick using UNetbootin, as was just suggested.

There are reports that you can fix the bug by opening syslinux.cfg on the USB drive and replace the following line:

ui gfxboot bootlogo

with

gfxboot bootlogo
share|improve this answer
1  
yeah i found the bug and its fix here: alexsleat.co.uk/2010/11/27/… now.. people knows there is the bug and knows how to fix it (remove 'ui' word in syslinux.cfg).. why it is not fixed in main distributions? –  nkint Apr 8 '11 at 12:07
    
ty for the info. Added it to answer :) –  Takkat Apr 8 '11 at 12:22

Okay, the problem is that you didn't format your USB to FAT32.

share|improve this answer
    
how to save the data inside anyway? –  nkint Apr 1 '12 at 21:55
    
Also try FAT16 (aka "FAT"). FAT32 is not bootable on some hardware, whereas FAT16 may be. –  Nik Aug 4 '13 at 7:31

You could try using UNetbootin, another tool for the same purpose of making bootable usb drives. It's in the repositories as unetbootin.

share|improve this answer

Actually, what worked for me [Dell Power Edge Server R220] was to copy the iso to usb in the following manner

I inserted usb drive then ran dmesg | tail to know the /dev/sd<x> drive.

If this drive has partitions then make sure you unmount invidual partitions sudo fdisk -l /dev/sd<x> first sudo umount /dev/sd<x1>; sudo umount /dev/sd<x2>; ... etc.

Then format this as follows sudo mkfs.msdos -I /dev/sd<x>

Now copy over the iso sudo dd if=<iso name>.iso of=/dev/sd<x> bs=1M && sync

share|improve this answer

I solved this problem by copying syslinux.cfg from one folder near the kernel to the base of the Key. In fact I once displaced it and the boot went one step further but syslinux.cfg was then missing to the boot. So I had to copy it back.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.