Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Hello Ubuntu Community,

I have been working with Linux for 5 years, and with those five years, I have never had a problem with the Ubuntu apt program. It usually works like a charm and is an instant way to get updates and software on the fly. But it seems that my computer cannot get it's proper updates, nor can apt-get update itself.

I am running Ubuntu 12.04 3.8.0-29-generic #42~precise1-Ubuntu x86_64 I am Intel dual core processor.

I installed 12.04 on my laptop which has similar specs to my tower, but there were no problems when I installed the Ubuntu on it.

So when I attempt to do sudo apt-get update I get the following:

Hit precise Release.gpg
Hit precise-updates Release.gpg
Hit precise-backports Release.gpg
Hit precise-security Release.gpg
Hit precise Release.gpg
Hit precise Release
Hit precise Release                         
Hit precise-updates Release
Hit precise-backports Release
Hit precise/main Sources                    
Hit precise-security Release
Hit precise/main amd64 Packages             
Hit precise/main i386 Packages
Ign precise/main TranslationIndex
Ign precise/main Translation-en
Hit precise/main Sources
Hit precise/restricted Sources
Hit precise/multiverse Sources
Hit precise/restricted amd64 Packages
Hit precise/multiverse amd64 Packages
Hit precise/main i386 Packages
Hit precise/restricted i386 Packages
Hit precise/multiverse i386 Packages
Hit precise/main TranslationIndex
Hit precise/multiverse TranslationIndex
Hit precise/restricted TranslationIndex
Hit precise/universe TranslationIndex
Hit precise-updates/restricted Sources
Hit precise-updates/universe Sources
Hit precise-updates/multiverse Sources
Hit precise-updates/main amd64 Packages
Hit precise-updates/restricted amd64 Packages
Hit precise-updates/universe amd64 Packages
Hit precise-updates/multiverse amd64 Packages
Hit precise-updates/restricted i386 Packages
Hit precise-updates/universe i386 Packages
Hit precise-updates/multiverse i386 Packages
Hit precise-updates/main TranslationIndex
Hit precise-updates/multiverse TranslationIndex
Hit precise-updates/restricted TranslationIndex
Hit precise-updates/universe TranslationIndex
Hit precise-backports/main Sources
Hit precise-backports/restricted Sources
Hit precise-backports/universe Sources
Hit precise-backports/multiverse Sources
Hit precise-backports/main amd64 Packages
Hit precise-backports/restricted amd64 Packages
Hit precise-backports/universe amd64 Packages
Hit precise-backports/multiverse amd64 Packages
Hit precise-backports/main i386 Packages
Hit precise-backports/restricted i386 Packages
Hit precise-backports/universe i386 Packages
Hit precise-backports/multiverse i386 Packages
Hit precise-backports/main TranslationIndex
Hit precise-backports/multiverse TranslationIndex
Hit precise-backports/restricted TranslationIndex
Hit precise-backports/universe TranslationIndex
Hit precise-security/main Sources
Hit precise-security/restricted Sources
Hit precise-security/universe Sources
Hit precise-security/multiverse Sources
Hit precise-security/main amd64 Packages
Hit precise-security/restricted amd64 Packages
Hit precise-security/universe amd64 Packages
Hit precise-security/multiverse amd64 Packages
Hit precise-security/restricted i386 Packages
Hit precise-security/universe i386 Packages
Hit precise-security/multiverse i386 Packages
Hit precise-security/main TranslationIndex
Hit precise-security/multiverse TranslationIndex
Hit precise-security/restricted TranslationIndex
Hit precise-security/universe TranslationIndex
Get:1 precise/universe Sources [6239 kB]
Get:2 precise/main amd64 Packages [1640 kB]
Get:3 precise/universe amd64 Packages [6167 kB]
Get:4 precise/universe i386 Packages [6180 kB]
Get:5 precise/main Translation-en [726 kB]
Hit precise/multiverse Translation-en                                            
100% [5 Translation-en bzip2 0 B] [Waiting for headers]                                         3422 kB/s 0s
bzip2: Data integrity error when decompressing.
    Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

Hit precise/restricted Translation-en                                            
Get:6 precise-updates/main Sources [504 kB]                                      
Get:7 precise-updates/main i386 Packages [888 kB]                                
Hit precise-updates/main Translation-en                                          
Hit precise-updates/multiverse Translation-en                                    
Hit precise-updates/restricted Translation-en                                    
Hit precise-updates/universe Translation-en                                      
Hit precise-backports/main Translation-en                                        
Hit precise-backports/multiverse Translation-en                                  
Hit precise-backports/restricted Translation-en                                  
Hit precise-backports/universe Translation-en                                    
Get:8 precise-security/main i386 Packages [406 kB]                               
Hit precise-security/main Translation-en                                         
Hit precise-security/multiverse Translation-en                                   
Hit precise-security/restricted Translation-en                                   
Hit precise-security/universe Translation-en                                     
Get:9 precise/universe Translation-en [4133 kB]                                  
Fetched 726 kB in 25s (29.0 kB/s)                                                                          
W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_universe_source_Sources  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_main_binary-amd64_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_universe_binary-amd64_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_universe_binary-i386_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise-updates_main_source_Sources  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise-updates_main_binary-i386_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise-security_main_binary-i386_Packages  Hash Sum mismatch

W: Failed to fetch gzip:/var/lib/apt/lists/partial/archive.ubuntu.com_ubuntu_dists_precise_universe_i18n_Translation-en  Encountered a section with no Package: header

E: Some index files failed to download. They have been ignored, or old ones used instead.

I remember seeing during the installation process and I was worried about it then. The first time I tried installing Ubuntu 12.04.3, the installer crashed and it said that it could not send off a report due to the software being 3rd party and that I should delete the 3rd party software. After that, I wiped my hard drive again, did a installation and after some time, it was complete... but I still got those errors when it installing, but no crash.

Also, ever time I try to install a program, I get this `

~$ sudo apt-get install apache2
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 apache2 : Depends: apache2-mpm-worker (= 2.2.22-1ubuntu1.4) but it is not going to be installed or
                    apache2-mpm-prefork (= 2.2.22-1ubuntu1.4) but it is not going to be installed or
                    apache2-mpm-event (= 2.2.22-1ubuntu1.4) but it is not going to be installed or
                    apache2-mpm-itk (= 2.2.22-1ubuntu1.4) but it is not going to be installed
           Depends: apache2.2-common (= 2.2.22-1ubuntu1.4) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

This happens with all programs I try to install, so now my ability to install software is broken too.

Lastly, I have tried almost everything I could find. Such as:

sudo apt-get clean
cd /var/lib/apt/lists/partial
sudo rm *
sudo apt-get clean
sudo apt-get update && sudo apt-get upgrade

same result.

sudo apt-get clean
mv /var/lib/apt /var/lib/apt.old
mv /var/cache/apt /var/cache/apt.old
sudo apt-get clean
sudo apt-get update && sudo apt-get upgrade

Also results in failure.

I even tried this link

How do I resolve unmet dependencies?

I thought that would have been my last stop and I would be done with the problem. But, I am still with it. Can anyone else help me to figure out what is wrong with my system?

share|improve this question
Are you using PPA's? What's the output of apt-cache policy apache2? What kind of internet you have? it is reliable? – Braiam Sep 3 '13 at 21:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.