Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a new ubuntu installation which is working 99% ok, except for one small problem with the fonts being displayed.

For sufficiently small fonts, pieces are missing.

As an example, here is a render of in Firefox with zoom standard.

enter image description here

There are a large amount of missing pixels or segments from the characters being displayed.

If I raise the zoom, these issues are still present, but the font is readable.

enter image description here

This process isn't a long term solution, as then I can't fit as much text on my screen as I need, and it happens in other applications as well, where I can't zoom at will.

I can't find a good resource that covers this, looking up anything with 'font' in the title leads to gnof.font configs (the fonts work though), or adding 'chunks missing' leads to minecraft compatibility on linux systems. :/

How might I fix this issue, and what's the correct term for what's happening here?

It's not just Firefox either, it's anything. I have the same problems in other applications, but they're usually of sufficiently large font to not be readily noticed.

share|improve this question

migrated from Apr 8 '11 at 3:56

This question came from our site for computer enthusiasts and power users.

Does it happen to all small fonts at all times, or only in Firefox? Not that I have a solution, but it seems similar to my problem:… – Aibara Iduas Apr 20 '11 at 5:08
What graphics card have you installed? Type lspci | grep VGA ... also do you have compiz or metacity effects enabled? What happens if you turn effects off? – fossfreedom Apr 20 '11 at 19:23
@AibaraIduas: Unsure how to update the drivers, but I'm getting similar problems just on the vertical plane. – glasnt Apr 21 '11 at 0:50
@FossFreedom: VGA Compatable controller: nVidia Corporation G71 I've tried changing the effects, but only No Effects works. – glasnt Apr 21 '11 at 0:51
The pieces of the font aren't missing - they are yellow. This suggests a problem with subpixel antialiasing such that the stroke is 1/3 of a pixel wide. – Alistair Buxton Apr 21 '11 at 23:50

To diagnose issues such as these, try the following:

  1. Examine to see if its a nouveau driver vs nvidia issue - i.e. the yellow pixel observation could show a driver issue. Try installing the nvidia drivers i.e. ensure you are connected to the internet - run Administration - Hardware Drivers. If you are offered a restricted NVidia driver that is not activated, then try activating it. Once installed type the following to set up your display.

    gksudo nvidia-settings

  2. Try rebuilding the ubuntu font cache through the following (i.e. may be the missing stuff is due to the fonts not being built or corrupted somehow)

    sudo fc-cache -v -f

share|improve this answer
If the problem was caused by the monitor it wouldn't show up in screenshots. – Alistair Buxton Apr 21 '11 at 23:37
ok - second try - I've edited my original answer. – fossfreedom Apr 22 '11 at 7:19
The fc-cache call didn't make any visual changes, and the nvidia-settings tried to launch the associated settings page, but failed. – glasnt Apr 26 '11 at 23:34

Try changing the type of, or disabling, subpixel smooting. System -> Settings -> Appearence, under the tab Fonts. Also: press Details... and try the different subpixel orders.

share|improve this answer
The Subpixel ordering makes things fuzzy, but no missing bits. The Hinting and Smoothing makes the fonts barely readable. I'll try some settings, see how I go. – glasnt Apr 26 '11 at 23:31

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.