Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently noticed my computer is highly sluggish (recent install of Kubuntu 13.04 by the way). I have a Toshiba Satellite P70-A PSPLPC-01Y007 laptop with an Intel i7 quad-core, 16 GB of ram. It appears to look correct in the kinfo. So I ran mpstat -P ALL:

Linux 3.8.0-30-generic (Isogen)         13-09-02        _x86_64_        (1 CPU)

10:07:13 AM  CPU    %usr   %nice    %sys %iowait    %irq   %soft  %steal  %guest   %idle
10:07:13 AM  all   11.07    3.02    2.90   36.25    0.00    0.12    0.00    0.00   46.64
10:07:13 AM    0   11.07    3.02    2.90   36.25    0.00    0.12    0.00    0.00   46.64

I noticed when I had chrome open with 10 tabs, typical of an engineer, but it kept freezing horribly. After I ran top, I realized the CPU kept hitting 100% and only one CPU/core is listed. Couldn't find a solution so far. How can I get it to register all 4 cores?

cat /proc/cpuinfo | grep -E "(core|model\ name)"
model name      : Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
core id         : 0
cpu cores       : 1

as well as

sudo grep -i smp /var/log/syslog
Sep  2 10:02:41 Isogen kernel: [    0.000000] Linux version 3.8.0-30-generic (buildd@roseapple) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 (Ubuntu 3.8.0-30.44-generic 3.8.13.6)
Sep  2 10:02:41 Isogen kernel: [    0.000000] found SMP MP-table at [mem 0x000fe1b0-0x000fe1bf] mapped at [ffff8800000fe1b0]
Sep  2 10:02:41 Isogen kernel: [    0.000000] smpboot: Allowing 1 CPUs, 0 hotplug CPUs
Sep  2 10:02:41 Isogen kernel: [    0.010390] Freeing SMP alternatives: 24k freed
Sep  2 10:02:41 Isogen kernel: [    0.062244] smpboot: CPU0: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz (fam: 06, model: 3c, stepping: 03)
Sep  2 10:02:41 Isogen kernel: [    0.063005] smpboot: Total of 1 processors activated (4788.97 BogoMIPS)
Sep  2 11:18:52 Isogen kernel: [    0.000000] Linux version 3.8.0-30-generic (buildd@roseapple) (gcc version 4.7.3 (Ubuntu/Linaro 4.7.3-1ubuntu1) ) #44-Ubuntu SMP Thu Aug 22 20:52:24 UTC 2013 (Ubuntu 3.8.0-30.44-generic 3.8.13.6)
Sep  2 11:18:52 Isogen kernel: [    0.000000] found SMP MP-table at [mem 0x000fe1b0-0x000fe1bf] mapped at [ffff8800000fe1b0]
Sep  2 11:18:52 Isogen kernel: [    0.000000] smpboot: Allowing 1 CPUs, 0 hotplug CPUs
Sep  2 11:18:52 Isogen kernel: [    0.010393] Freeing SMP alternatives: 24k freed
Sep  2 11:18:52 Isogen kernel: [    0.062271] smpboot: CPU0: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz (fam: 06, model: 3c, stepping: 03)
Sep  2 11:18:52 Isogen kernel: [    0.063032] smpboot: Total of 1 processors activated (4788.73 BogoMIPS)

EDIT: But when I run sudo lshw -class cpu, I get this:

*-cpu                   
       description: CPU
       product: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
       vendor: Intel Corp.
       physical id: 4
       bus info: cpu@0
       version: Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz
       serial: To Be Filled By O.E.M.
       slot: U3E1
       size: 2400MHz
       capacity: 2400MHz
       width: 64 bits
       clock: 100MHz
       capabilities: x86-64 fpu fpu_exception wp vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp constant_tsc arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf eagerfpu pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 fma cx16 xtpr pdcm pcid sse4_1 sse4_2 movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid
       configuration: cores=4 enabledcores=4 threads=8

So it recognizes that it has 4 cores with 8 threads, as well as says that all 4 cores are enabled. It is also hyper-thread, so even if running only on one core, it should see two.

share|improve this question
1  
This should run out of the box. Please check the computer's BIOS. It has a setting to disable the other cores for compatibility reasons (older OSs). I think it's very likely that setting is on. –  gertvdijk Sep 2 '13 at 17:55
    
Thanks for the response. I just checked, and I could not find such an option. Only legacy mode setting I have enabled is after disabling UEFI. –  user1553176 Sep 2 '13 at 18:22
    
Please include the output of cat /proc/cpuinfo | grep -E "(core|model\ name)" in your question. Please also run sudo grep -i smp /var/log/syslog –  gertvdijk Sep 2 '13 at 18:31
    
smpboot: Allowing 1 CPUs - well, there you have it. Upgrade the BIOS and double check you didn't disable the other cores. Please also note that this is a very new Haswell CPU, which may not be supported very well. What brand/type laptop is this exactly? –  gertvdijk Sep 2 '13 at 18:46
    
I just purchased this laptop about a month ago, it is a: Toshiba satelite P70-A PSPLPC-01Y007 The only change has been the change to kubuntu. –  user1553176 Sep 2 '13 at 19:06
show 3 more comments

1 Answer

up vote 4 down vote accepted

[SOLVED] - I don't know if I should feel foolish about this.

The answer is odd, and rather simple, however taking more than a day to determine the root behind this issue. There have been many problems with almost every distro of linux on this machine, from no wireless, graphics issues etc.etc. I realized I couldn't have been the only person with this processor running linux, so I managed to find some forums regarding the same issue with this particular chipset running only one core. And it turns out if you run in acpi=off, then the kernel will only utilize one core, and on one thread. That solution worked for that particular individual, however acpi=off was the only way to actually install linux, period. nomodeset would get you to the install screen, but the try out ubuntu/kubuntu screens were... just not there, not rendering. And as this was listed as a viable option for getting rid of the black screen problem, I had done just that, without any mention that this would disable cores, wireless networks, the fan etc.

After many attempts at different solutions, I had decide to do a fresh install with nomodeset anyway, despite not being able to render the desktop. Upon restarting after the installation, everything worked fine. Every issue i've had seems to have been resolved, minus testing if unity still breaks. I'm not sure why it doesn't have any issues now, nomodeset isn't set, as that is temporary for the install process, and I do get the splash screen, I'm going to assume it had something to do with it being a usb 3.0 installation issue.

share|improve this answer
    
Thanks for writing back with the answer. Please mark your answer as the solution. –  Sparhawk Sep 3 '13 at 12:56
1  
No Problem, and I will. It tells me to wait until tomorrow before I can. –  user1553176 Sep 3 '13 at 13:00
    
Oh okay. I didn't realise it had that restriction. Cheers. –  Sparhawk Sep 3 '13 at 13:21
    
Although it may have been the case that using acpi=off caused your kernel to only use one core, I just thought I would clarify that this is not the universal case. In my case, it enabled my computer to use all of it's cores. Thank you for the helpful reminder to explore boot options when things go wrong. –  Seanny123 Nov 8 '13 at 1:02
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.