Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i was recently making some researches about the passwd file, and out of curiosity i deleted it, after i deleted it my computer froze, and after a hard reboot it doesnt boot. i found a solution on this site but it had to do with restoring a backup of the deleted file. so on my own accord i ran a live-cd and copied passwd- as the new passwd file, now the computer boots to the login screen but the screen keeps flicking with a black boot screen.

please i need your help, i have several works on hold for the past 2 days.

thank you.

p.s i am using ubuntu 13.04

share|improve this question
    
I can't really imagine a missing passwd file resulting in the symptoms you describe. I'd look into alternative causes as well. –  Gerald Schneider Sep 3 '13 at 11:33
    
my problem actually started immediately i deleted the passwd file, but i will appreciate it if you had any suggestions on my problem. thank you –  Salman Sep 3 '13 at 18:47
add comment

1 Answer 1

There should have been a recent backup of your original passwd file at /var/backups/passwd.bak

Try booting from the live CD again and copying that file, instead of the one from the live CD. For example, if you have mounted the old filesystem at /mnt/oldsys then

sudo cp /mnt/oldsys/var/backups/passwd.bak /mnt/oldsys/etc/passwd

It will be slightly more complicated if your old system has a separate /var partition, but basically the same process. Then make sure the permissions on the copied file are correct

sudo chmod 644 /mnt/oldsys/etc/passwd
share|improve this answer
    
i tried the solution you suggested, i copied the the backup of the passwd file (passwd.bak), but i still had no response, so i copied the passwd.bak as passwd thinking the .bak extension was stopping it from being read. this time around i had a response but the same as when i copied the passwd- file. thank you –  Salman Sep 3 '13 at 8:01
    
You may need to re-set the permissions on the copied file (they should be -rw-r--r--) - see my edit about chmod –  steeldriver Sep 3 '13 at 11:29
    
can you please give me a link to your edit on chmod, for now i ran sudo chmod -rw-r--r-- passwd, but it still did not work. thank you so much for your responses, i really appreciate them. i am grateful –  Salman Sep 3 '13 at 18:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.