Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have deployed 3 ceph mon nodes using juju and maas. From juju status all ceph mon nodes are up and fine. but i did ssh into one of the ceph node and was just trying to get ceph status. and its giving me this error,

ubuntu@CS1:/home/ubuntu# sudo ceph status
2013-09-02 11:01:32.157892 7f8fc3d65780 -1 monclient(hunting): ERROR: missing keyring, cannot use cephx for authentication
2013-09-02 11:01:32.157928 7f8fc3d65780 -1 ceph_tool_common_init failed.

And then i discovered for any ceph command its giving me same error.

Before ceph deployment in .yaml file i had sepecifed $fsid and $monitor-secret values. So i think juju should take care of keyring, but looks like it doesn't. Any suggestion?

share|improve this question

2 Answers 2

I think you are probably hitting this bug:

https://bugs.launchpad.net/ubuntu/raring/+source/ceph/+bug/1218852

Right now the version of Ceph in 13.04 and the Ubuntu Cloud Archive for Grizzly can't deal with uppercase letters in hostnames.

Your hostname appears to be 'CS1'.

share|improve this answer
    
fwiw an update for ceph has been released which should fixup the capital hostname problem some folks have seen. –  jamespage Nov 11 '13 at 14:28
up vote 1 down vote accepted

Looks like mistake from my side, while generating monitor secret, i didnt specified name parameter, so i regenerated monitor secrete with that parameter like this,

sudo ceph-authtool /dev/stdout --name=mon. --gen-key

And redeployed ceph mon and OSDs, but this time i also took care of capital letters.That information was also helpful James.Thx !

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.