Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I installed ubuntu 12.04 LTS and it was working properly. I didnt use for one month and now when i boot it the screen becomes blank with a cursor blinking on it. What is the problem?

share|improve this question

marked as duplicate by Stephen Myall, guntbert, Kevin Bowen, RolandiXor Sep 2 '13 at 16:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 0 down vote accepted

Reconfiguring Lightdm can fix your problem

  • Press CTRL+ALT+F1 when blank screen appears.
  • If tty1 CLI appears then login with your user name and execute following commands

    sudo dpkg-reconfigure lightdm
    

    then chose lightdm from the list, and restart your system:

    sudo reboot now
    

If this doesn't work then you have to follow following methods.


Installing GDM (a display manager like lightdm) can fix your problem:

Method 1:

  • This method works when you are able to go to at least the command line interface.

Press CTRL+ALT+F1 or CTRL+ALT+F2 when your system starts and starts freezing or black screen appears. It will let you to use Command Line Interface. Then login using your username and password, and try following commands:

$ sudo apt-get install gdm
$ sudo dpkg-reconfigure gdm

then selected gdm from the list, and restarted your system:
$ sudo reboot

Your system will be restarted with a login screen which will let you to access your system.

Method 2: If 1st didn't work for you then you can try this method. But it would be very long for you:

Here are the steps how to install using 2nd method

  • Go to following link and download gdm for Ubuntu 12.04.2 amd64. (chose ubuntu proposed universe out of three listed there.)

    http://pkgs.org/download/gdm

  • Put the *.deb file just installed to any pendrive.

  • Then login in save mode or Recovery Mode. After a lot of text displayed in black

    screen one window will come which list some options. First go to option Grub, it will mount your file system in read/write mode. Then chose root option in order to login as root. Then go to the pendrive where you saved the deb file. The drive should be listed in in /media. I am assuming that you saved the file in gdm directory inside pendrive (pendrive is the name of your pendrive)

    # cd /media && ls
    

    (which will list your pendrive if you don't get pendrive folder then go to Mount Pendrive Section at last, then come back here and continue to next step.)

    # cd /media/pendrive/gdm 
    

    (go to gdm directory where .deb file is saved.)

    # dpkg -i *.deb   
    

    (installing gdm) While installing gdm one window will come which will ask your to chose lightdm or gdm from the list. Chose gdm. If this window doesn't appear then try following command:

    # dpkg-reconfigure lightdm 
    

    (chose gdm) Then finally execute following command:

    # reboot (reboot your system)
    

Mount Pendrive Section

  • Mounting pendrive while working in recovery mode.

Run this command:

    # fdisk -l

Find your device in the list, it is probably something like /dev/sdb1. Then execute other commands one by another:

    # mkdir /media/pendrive
  • Run this command if your pendrive is formatted in FAT/FAT32.

    # mount -t vfat /dev/sdb1 /media/pendrive -o uid=1000,gid=1000,utf8,dmask=027,fmask=137
    
  • Or this command if your pendrive is formatted in NTFS

    # mount -t ntfs-3g /dev/sdb1 /media/pendrive
    

Hope it will work for you.. For any further assistance please reply..

share|improve this answer
    
ok thanks.. it worked after reconfiguring lightdm. –  Rohit Agarwal Sep 2 '13 at 10:33
    
hey.. i did reconfiguration of lightdm and when rebooted i was able to login to ubuntu. but from the next time onwards the same black screen again appears and now even tty1 CLI doesnt appear. Also i tried recovery mode but the same case there also. I tried boot repair , but no use . –  Rohit Agarwal Sep 3 '13 at 18:56
    
Did you install gdm as suggested in Methods? –  Saurav Kumar Sep 3 '13 at 18:59
    
As said in method one , i can get to cli now. Dont know why. And as in method two i cant login to recovery , it shows the same problem. After grub menu a blank screen with cursor blinking. The screen isnt freezed as whatever i type appears on screen. –  Rohit Agarwal Sep 3 '13 at 19:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.