Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is my first time asking a question on here, bare with me. So I have a brand new ThinkPad X131e with a Broadcom Corporation BCM43228 802.11a/b/g/n wireless card. I currently have it dual booting Ubuntu 12.04 LTS and Windows 7 Professional. I am able to connect to wifi on Windows but not on Ubuntu. When I try to install the driver with the "Install Additional Drivers" tool I get the the error

"Sorry, installation of this driver failed.

Please have a look at the log file for details: /var/log/jockey.log"

I have tried using the firmware-b43-installer and b43-fwcutter packages, neither of which have done any good. I have tried uninstalling and re installing the bcmwl-kernel-source which did nothing. I have also been running

sudo apt-get update

in between most of my changes and I have restarted my system multiple times.

I have also tried downloading the driver from Broadcom and following the readme file install the driver which did not work.

Please let me know if you know of anything that I haven't tried.

Thanks in advance.

share|improve this question

1 Answer 1

The bcmwl-kernel-source package (For Broadcom STA Drivers) before 12.10 sometimes does not install the Linux Headers which gives an installation error if doing it via Additional Hardware or Jockey

So install the following packages using,

sudo apt-get install linux-libc-dev libc6-dev linux-headers-generic linux-headers-$(uname -r)

then reinstall bcmwl-kernel-source

sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

Also can have a read here - How do I get my BCM43228 card working in mainline kernel 3.4 or higher? --> But this should not be the cause.

More details answer on all broadcom device - http://askubuntu.com/a/60395/35775

share|improve this answer
    
Thank you for your quick reply Web-E. I tried what you said and this is the result: –  user189349 Sep 2 '13 at 16:21
    
I tried what you said. It was saying that the first list of packages you suggested were already installed. I uninstalled them and then re installed them. I uninstalled the bcmwl-kernel-source package and re installed it. Right after it was done installing my computer gave me a message saying that there was some sort of error with a package and asked if I wanted to report it. Running sudo modprobe wl yielded several "Fatal Errors" like Fatal: Module wl not found. I looked at what was on your other two links and I had tried most of what was on there. –  user189349 Sep 2 '13 at 16:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.