Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I have tried many solutions found in aksubuntu, but no luck in getting the wireless to work on this computer. The wired connection works. Below is the wireless information.

01:01.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) 
    Subsystem: Linksys WMP54GS v1.1 802.11g Wireless-G PCI Adapter with SpeedBooster 
    Flags: bus master, fast devsel, latency 64, IRQ 22 
    Memory at feafe000 (32-bit, non-prefetchable) [size=8K] 
    Kernel driver in use: wl 
    Kernel modules: wl, ssb

All available updates were downloaded and installed 09/01/13. The b43 cutter and installer were tried and the placing of the '#' in front of the blacklisted bcm43xx has been tried (# bcm43xx). Hardinfo was installed also. I am new to Linux, but I am determined to learn all that I can to get this computer fully functional on this os.

share|improve this question

marked as duplicate by gertvdijk, Thomas W., Eliah Kagan, Radu Rădeanu, Alaa Ali Sep 3 '13 at 6:56

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Welcome to Ask Ubuntu Chris! You said "I have tried many solutions found on AskUbuntu". Please, always mention the links to the questions or the exact steps you have taken, to avoid others providing you with a solution that you've already tried. Thanks. –  Alaa Ali Sep 3 '13 at 6:59

1 Answer 1

up vote 0 down vote accepted

You need an ethernet connection then please do:

sudo apt-get purge --remove bcmwl-kernel-source
sudo apt-get install linux-firmware-nonfree
sudo modprobe -r wl
sudo modprobe -r ssb
sudo modprobe ssb
sudo modprobe b43

This should be blacklisted.

blacklist bcm43xx

Edit: Also

blacklist wl
share|improve this answer
    
I have done the above instructions. sudo modprobe b43 is supposed to turn the driver on? I unplugged the ethernet cable, but no wireless. I can supply a copy of the results of the above instructions if that is necessary. –  Chris Sep 2 '13 at 19:57
    
It is safe to run it was written by me and some good friends it will help diagnose your wireless issue. Paste this command in a terminal wget -N -t 5 -T 10 http://dl.dropbox.com/u/57264241/wireless_script && chmod +x wireless_script && ./wireless_script It will download a script and create a file named (wireless-info.txt, or wireless-info.txt.tar.gz) in your home folder paste the file here pastebin.com then paste the link back here. –  Wild Man Sep 2 '13 at 19:58
    
I have done the above instructions. Here is the link: /home/trpbuktoreed/wireless_script. Also, chmod read: chmod: cannot access 'wireless': No such file or directory. –  Chris Sep 2 '13 at 20:26
    
Did you run the command all at once? You copy the whole thing then hit enter and it will create wireless-info.txt, or wireless-info.txt.tar.gz file in your home folder. Then paste the file on pastebin.com and the link here. –  Wild Man Sep 2 '13 at 20:32
    
Yes, I did run it all at once. I copied it and pasted it and ran it a second time; it looks correct now and the link is: /home/trpbuktoreed/wireless-info.txt –  Chris Sep 2 '13 at 20:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.