Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

OK, so it seems this question has been asked before but not successfully answered. I have a Windows 8 Toshiba P75-A7200, and I've disabled Secure Boot, Fast Boot, and Fast Startup. Still, when I try to boot a Ubuntu 13.04 USB installer, I get to the GRUB screen and when I select "Try Ubuntu Before Installing," it hangs on a black screen. I had also tried booting in Legacy Mode, and it was the same.

The answers that I've seen haven't helped me, since they seem to assume I can access the Ubuntu terminal?

I've read this: My computer boots to a black screen, what options do I have to fix it? But disabling secure boot and enabling BIOS Legacy Mode didn't help. My computer doesn't have an UEFI/BIOS option; only UEFI or BIOS.

Same with this: Installing Ubuntu on a Pre-Installed Windows 8 (64-bit) System (UEFI Supported) It suggests the same things, which don't work.

They both assume that I can get to the Ubuntu installer. I've also tried to install Linux Mint, and it was still unresponsive. I used 64bit for both, of course.

So Ubuntu is supposed to be able to work with UEFI and secure boot. What's going wrong?

PS It is a black screen, not a purple screen, so I don't think the problem is my video drivers, because I've had that happen on another computer. I know the problem is the UEFI, since I've installed Linux on three other Windows 7 computers just fine.

EDIT: dd just try to switch to nomodeset, and that took me to the ubuntu command line. I tried startx which resulted in an error, so I am lost on how to proceed?

share|improve this question
1  
Search this forum for Toshiba P75 A7200 to see how others solved this problem. –  ubfan1 Sep 1 '13 at 23:57
add comment

2 Answers 2

up vote 2 down vote accepted

Try these instead of nomodeset or in addition to nomodeset: acpi_osi=Linux acpi_backlight=vendor

Since you have a very new system, you may really need all the fixes that will be in 13.10 as both Kernel & Intel drivers have changes. But we only suggest 13.10 for those users who realize that is it not final, may crash and those bugs need to be reported so additionally fixes can be made. Or you are a tester not a user.

share|improve this answer
    
That worked, but after I installed ubuntu, it went to a purple screen and then a black screen before getting to GRUB, so I didn't have the chance to add acpi_osi=Linux acpi_backlight=vendor. How would I do that now? –  laura Sep 2 '13 at 2:53
    
Do you get grub menu? Or is it directly booting as you only have Ubuntu on system? Holding shift form BIOS/UEFI start or sometimes escape with UEFI systems should then give menu. If you need the settings permanently you need to edit /etc/default/grub and replace or add to the line with quiet splash. –  oldfred Sep 2 '13 at 17:59
    
Oh, it looks like I just had to install boot repair while running the live image. Then I could get to the grub screen again and could add that into the grub file permanently. Thanks! –  laura Sep 3 '13 at 19:57
add comment

I'm adding a link to a post I made on coderwall after figuring it out, in case anyone is reading this who is having the same problems I was: https://coderwall.com/p/ydbldg

At the GRUB screen: You can either try Ubuntu or just install it, but before I did this I had to press 'e' and then revise the script. Before "quiet splash," I included "acpi _ osi=Linux acpi _ backlight=vendor". Then it should load without issue into the Ubuntu GUI.

While installing, if the installer doesn't recognize the existing Windows OS, you will have to select the "Something else" option and manually partition. In the end, Windows 8 will still be there, so don't worry. Select the partition you created and within it create a swap partition at about 10% of the size of the partition itself. The video I linked above explains this much better than I can. Then complete the installation.

If you try to reboot the computer and it loads onto a black screen again, don't fear. Restart the computer using the LiveCD and install boot-repair from the LiveCD:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

sudo apt-get install boot-repair

In boot-repair, just click on the "Recommended" button. It will fix the GRUB screen so you can see Ubuntu and Windows, although Windows is named something weird in the menu, it still works. Restart the computer.

You should see the GRUB screen. Select Ubuntu and press 'e'. Repeat step 4 so you can get into Ubuntu. To fix the black screen problem permanently, edit this line in /etc/default/grub:

GRUB _ CMDLINE _ LINUX _ DEFAULT="acpi _ osi=Linux acpi _ backlight=vendor quiet splash"

Then in a terminal, do "sudo update-grub" and restart.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.