Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a got a peculiar problem with my WiFi on my Dell Inspiron 1545 and would massively appreciate any help!

I am a total noob to Linux/ Ubuntu and decided to give my wife's Dell Inspiron 1545 (32bit) old laptop a facelift and make it usable again. I had a bootable USB stick with Ubuntu on it, which I had created last week to do the same job on my old netbook (Dell Inspiron mini 1011).

When I installed Ubuntu from the USB stick, the WiFi did not work- it is enabled, but does not pick up a network. I have add the home network on the list of networks, but still no joy! My situation is peculiar because, when I run Ubuntu straight from the USB stick- the WiFi signal is picked up and the network is connected!! So, I am reasonably assured that there is no Hardware problem.

I have gone through lots of forum advices and advices listed on askubuntu, and here is what I have tried (& failed) so far:

  1. Checked BIOS- the wifi setting appear in order- they are enabled.
  2. Tried "Fn-F2" and "Alt-Fn-F2": but no change
  3. Typed in the command lines that I picked up on the forums:
    • rfkill list all: does not seem to work and does not produce any list
    • rfkill unblock all: does not seem to work

I am not sure what I am missing and what's frustrating is that the WiFi is working when Ubuntu is run from the USB drive, but not from the one installed on the hard drive! Please help!! Thanks

Edit: Here are the details of my WiFi device:

ubuntu@ubuntu:~$ lspci -nn | grep 0280 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)

share|improve this question
    
Please edit your question to add details of your wireless device from the terminal command: lspci -nn | grep 0280 –  chili555 Sep 1 '13 at 12:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.