Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to install Ubuntu 13.04 on an HP desktop machine. I made a partion of 20 GB in Wndows 8 and created a installation USB and installed it. After that when I reboot I couldn't get to GRUB. So I boot into usb and did the recomended boot repair. It said 'EFI detected' and I clicked yes on all of it. I also got this link http://paste.ubuntu.com/6049761/ and message. The message was to disable secure boot. So I disabled secure boot and didn't turn on Legacy boot(am I suppose to do that). Now I cannot boot to Windows 8 What do I do? Please help. Please, please, please.

share|improve this question

closed as unclear what you're asking by Braiam, Radu Rădeanu, Raja, Stephen Myall, guntbert Sep 2 '13 at 15:58

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What is the computer doing now? Can you see a grub menu? –  Richard Sep 1 '13 at 2:07

3 Answers 3

Your efibootmgr output (part of the Boot Repair results, on lines 934-945 and 983-994) indicates that the Windows boot loader (Boot0000) is set as the default boot loader, and there's no entry for Ubuntu's GRUB. In theory, Boot Repair should have fixed this; but it didn't. You can try fixing it by using efibootmgr manually, as described here. In brief, you should boot a Linux live CD in EFI mode and type the following command:

sudo efibootmgr -c -d /dev/sda -p 2 -l \\EFI\\ubuntu\\shimx64.efi -L Ubuntu

Reboot. In theory, this should fix the problem.

Unfortunately, in practice, many HP computers are known to have buggy EFIs that refuse to launch any boot loader except for EFI/BOOT/bootx64.efi or EFI/Microsoft/Boot/bootmgfw.efi. Thus, you may need to use an ugly hack to get this to work. This is most easily done with Boot Repair: Run it again, but select the advanced options button and check the option to "Back up and rename Windows EFI files." This will install GRUB as EFI/Microsoft/Boot/bootmgfw.efi, moving that file to a new name and configuring GRUB to launch it.

share|improve this answer

If your HP was bringing Windows 8 preinstalled, and want to continue using it, then you should not install Ubuntu in legacy mode, you should install Ubuntu on EFI mode. Reinstall Ubuntu following the steps described here -> https://help.ubuntu.com/community/UEFI

share|improve this answer
    
There's no evidence that Ubuntu was installed in legacy mode; if it had been, Boot Repair would have detected GRUB in the disk's MBR, but it didn't. I therefore recommend against re-installing Ubuntu, since it will be wasted effort and could create further confusion about what's going on. –  Rod Smith Sep 1 '13 at 17:06

Your log shows that you used Boot-Repair before disabling SecureBoot. I understand that you disabled it later, so you need to re-run Boot-Repair.

  1. Make sure that you have disabled SecureBoot in your BIOS
  2. run Boot-Repair --> Recommended Repair. Answer Yes to the Do you want to activate [Backup and rename Windows EFI files]? question. It will ask you to connect internet and type some commands in a terminal. Write on a paper the new URL that will appear.
  3. Reboot. You should now have access to both Windows and Ubuntu.
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.