Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to edit my keyboard layouts, because randomly? my keyboard layout will switch from 'English (Canada)' to 'English', completely screwing up how I type, and the only way I have found to fix it is to log out out of my session and select 'English (Canada)' on the login screen.

Apparently, I think I'm supposed to have the "Keyboard Layout" application, but it is nowhere to be found, it seems like it isn't installed on my OS, and I have no idea what to install to enable it.

Thank you!

share|improve this question
    
Welcome to Ask Ubuntu, by the way. I hope your keyboard problem gets fixed soon! –  Jorge Suárez de Lis Sep 1 '13 at 0:25

1 Answer 1

Go to System Settings, and choose Keyboard Layout

Just add the desired layouts, and a new icon will appear on the right top corner of the screen, along with the other notification icons, and you can switch the layout from there at any time.

In addition, please make sure the option Use the same distribution for all the windows is the one selected. It's much easier that way.

share|improve this answer
    
Thank you, I was able to find the Keyboard Layout window, but sadly it doesn't help my issue at all. Only 'French (Canada)' is listed (sorry, wrongly stated English in my question), and yet my keyboard layout still manages to switch to English sometimes. –  Xifanie Sep 1 '13 at 0:52
    
Just add English, and then put French (Canada) on the top of the list, and make sure it's selected on the icon I told you. This way you luckily can figure out what action is making the keyboard layout to be swithed, since the icon shows the current keyboard layout. –  Jorge Suárez de Lis Sep 1 '13 at 1:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.