Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed Ubuntu 13.04 with my Pavilion dv6. My laptop originally was operated under Windows 7. My WiFi worked fine when it was still on Windows 7. However, after I changed the OS to Linux using Ubuntu 13.04, the WiFi stopped working anymore. I can see the network list. I can also use wired network, and it is fine. I just cannot connect to my router even with the correct password.


01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
03:00.1 SD Host controller: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
share|improve this question

1 Answer 1

up vote 2 down vote accepted

Please get a temporary wired ethernet connection, open a terminal and do:

sudo -i
apt-get remove --purge bcmwl-kernel-source
apt-get install linux-firmware-nonfree
echo brcmsmac >> /etc/modules

Detach the ethernet, reboot and tell us if it is working.

If you suffer poor signal strength, a well documented bug: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/856314; I suggest you try the brcmsmac driver backported from kernel version 3.11. Obtain a temporary wired ethernet connection, open a terminal and do:

sudo apt-get install build-essential linux-headers-generic

Download this file to your desktop: https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.11-rc3/backports-3.11-rc3-1.tar.bz2 Right-click it and select 'Extract Here.' Now back to the terminal:

cd Desktop/backports-3.11-rc3-1
make defconfig-wifi
sudo make install

You may get a comment about a private key. Unless it is mentioned as an error, it may safely be ignored. Reboot and let us know the result.

If signal strength is still low, try an earlier bcmwl-kernel-source as mentioned here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1110139/comments/42

wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_amd64.deb

Or if yours is a 32-bit system:

wget http://us.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_5.100.82.112+bdcom-0ubuntu3_i386.deb

Confirm 32- or 64-bit:


Then do:

sudo dpkg -i bcmwl*.deb

Reboot and give us your report.

share|improve this answer
Yes, it works now. The problem right now is that the signal is very weak even though my laptop is just right next to the router. Is there any way that i can fix the connection? Thanks for your time. –  ed12al Sep 1 '13 at 0:18
Can you join me in a chat room? chat.stackexchange.com/rooms/10386/intel I am there now. –  chili555 Sep 1 '13 at 0:34
it requires me to have 20 reputation and i am just have 6. sorry. –  ed12al Sep 1 '13 at 0:41
I am editing my answer to suggest a next step. –  chili555 Sep 1 '13 at 0:43
although "private key" was mentioned, no error was reported. However, the signal still is weak after rebooting. –  ed12al Sep 1 '13 at 1:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.