Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Having real problems getting Ubuntu 13.04 running properly on a Sony Vaio VGC-JS1E All In One desktop PC. I also have no sound, but this question is about screen resolution.

The panel in the PC has a native resolution of 1680 x 1050. I can't find any further information than that, including refresh rate. Graphics are Intel. On first install the screen defaults to a low resolution at top-left of the screen, the remainder being filled with repeats of the far-right and bottom pixel columns/rows. I can change the resolution to a higher one in Ubuntu settings, but the native resolution does not appear in the list. Also there's a second panel detected even though I don't have one connected. I understand this may be something to do with an HDMI output though, even though it's not in use.

I tried adding it with xrandr but the area outside the maximum resolution in the list (1600 x 1200) is hidden (the mouse pointer disappears behind the repeating pixels). So I got to work looking on the forums to create an xorg.conf file with an appropriate Modeline and various options to force X to only use one screen (which works) and to ignore the false EDID information from the screen and use the Modeline instead. Everything I try, however, seems useless.

Having checked Xorg.0.log, this section seems to apply (it's also repeated a few times):

[  1439.982] (II) intel(0): EDID for output LVDS1
[  1439.982] (II) intel(0): Not using mode "1680x1050_60" (exceeds panel dimensions)
[  1439.982] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "576x432" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "680x384" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "720x450" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "800x512" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "840x525" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "960x540" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "960x600" (doublescan mode not supported)
[  1439.982] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[  1439.982] (II) intel(0): Printing probed modes for output LVDS1
[  1439.982] (II) intel(0): Modeline "1600x1200"x60.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 -hsync -vsync (75.0 kHz eP)
[  1439.982] (II) intel(0): Modeline "1600x1024"x60.2  103.12  1600 1600 1656 1664  1024 1024 1029 1030 +hsync +vsync (62.0 kHz d)
[  1439.982] (II) intel(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[  1439.982] (II) intel(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[  1439.982] (II) intel(0): Modeline "1440x900"x59.9  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz d)
[  1439.982] (II) intel(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[  1439.982] (II) intel(0): Modeline "1360x768"x59.8   84.75  1360 1432 1568 1776  768 771 781 798 -hsync +vsync (47.7 kHz d)
[  1439.982] (II) intel(0): Modeline "1360x768"x60.0   72.00  1360 1408 1440 1520  768 771 781 790 +hsync -vsync (47.4 kHz d)
[  1439.982] (II) intel(0): Modeline "1152x864"x60.0   81.62  1152 1216 1336 1520  864 865 868 895 -hsync +vsync (53.7 kHz d)
[  1439.982] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[  1439.982] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[  1439.982] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[  1439.982] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)

Here's my xorg.conf:

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Screen "screen1"
EndSection

Section "Files"
    ModulePath   "/usr/lib/xorg/modules"
    FontPath     "/usr/share/fonts/X11/misc"
    FontPath     "/usr/share/fonts/X11/cyrillic"
    FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath     "/usr/share/fonts/X11/Type1"
    FontPath     "/usr/share/fonts/X11/100dpi"
    FontPath     "/usr/share/fonts/X11/75dpi"
    FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "auto"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier "LVDS1"
    HorizSync 30-81
    VertRefresh 56-75
    Option   "NoUseBios"
    Option "PreferredMode" "1680x1050_60"
    Modeline "1680x1050_60"  147.14  1680 1784 1968 2256  1050 1051 1054 1087 -HSync +VSync
    Option "DPMS"
EndSection

Section "Monitor"
    Identifier "VGA1"
    Option "Ignore" "True"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
    Identifier  "Card0"
    Driver      "modesetting"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"              # [<bool>]
        #Option     "kmsdev"                # <str>
        #Option     "ShadowFB"              # [<bool>]
    Identifier  "Card1"
    Driver      "modesetting"
    BusID       "PCI:0:2:1"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
    Identifier  "Card2"
    Driver      "intel"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "NoAccel"               # [<bool>]
        #Option     "AccelMethod"           # <str>
        #Option     "Backlight"             # <str>
        #Option     "DRI"                   # <str>
        #Option     "ColorKey"              # <i>
        #Option     "VideoKey"              # <i>
        #Option     "Tiling"                # [<bool>]
        #Option     "LinearFramebuffer"     # [<bool>]
        #Option     "SwapbuffersWait"       # [<bool>]
        #Option     "TripleBuffer"          # [<bool>]
        #Option     "XvPreferOverlay"       # [<bool>]
        #Option     "HotPlug"               # [<bool>]
        #Option     "RelaxedFencing"        # [<bool>]
        #Option     "XvMC"                  # [<bool>]
        #Option     "ZaphodHeads"           # <str>
        #Option     "TearFree"              # [<bool>]
        #Option     "PerCrtcPixmaps"        # [<bool>]
        #Option     "FallbackDebug"         # [<bool>]
        #Option     "DebugFlushBatches"     # [<bool>]
        #Option     "DebugFlushCaches"      # [<bool>]
        #Option     "DebugWait"             # [<bool>]
        #Option     "BufferCache"           # [<bool>]
    Identifier  "Card3"
    Driver      "intel"
    BusID       "PCI:0:2:1"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "Rotate"                # <str>
        #Option     "fbdev"                 # <str>
        #Option     "debug"                 # [<bool>]
    Identifier  "Card4"
    Driver      "fbdev"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"              # [<bool>]
        #Option     "DefaultRefresh"        # [<bool>]
        #Option     "ModeSetClearScreen"    # [<bool>]
    Identifier  "Card5"
    Driver      "vesa"
    BusID       "PCI:0:2:0"
EndSection

Section "Device"
    Identifier "device1"
    Driver "intel"
    # Option "DPMS"
    # Option "AccelMethod" "UXA"
    Option "monitor-LVDS" "LVDS1"
    Option "IgnoreEDID" "true"
    Option "NoDDC" "true"
    # Option "monitor-VGA" "VGA1"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "LVDS1"
    DefaultDepth 24
    Option "UseEDID" "false"
    Option "UseEDIDDpi" "false"
    Option "ModeDebug" "true"
    Option "ExactModeTimingsDVI" "true"
    Option "ModeValidation" "NoWidthAlignmentCheck, NoDFPNativeResolutionCheck"
    Option "TwinView" "0"
    Subsection "Display"
        Depth 24
        Modes "1680x1050"
    EndSubsection
EndSection

Also modified the following in /etc/default/grub, to no avail:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="
GRUB_CMDLINE_LINUX="video=LVDS1:1680x1050"

Any advice would be very gratefully received!

Thanks,

Andy

share|improve this question
    
How did you derive Modeline? Have you tried this with -r when calling cvt? –  mlt Aug 31 '13 at 20:00
    
Thanks @mlt I used "cvt 1680 1050 60" to derive the Modeline. Using "cvt -r 1680 1050 60" results in this: # 1680x1050 59.88 Hz (CVT 1.76MA-R) hsync: 64.67 kHz; pclk: 119.00 MHz Modeline "1680x1050R" 119.00 1680 1728 1760 1840 1050 1053 1059 1080 +hsync -vsync Result in replacing it in xorg.conf is no change. –  dang3rm0u5e Aug 31 '13 at 20:51
    
Hmmm, also xrandr is throwing this back at me on --addmode: X Error of failed request: BadMatch (invalid parameter attributes) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 18 (RRAddOutputMode) Serial number of failed request: 23 Current serial number in output stream: 24 –  dang3rm0u5e Aug 31 '13 at 21:38
add comment

1 Answer 1

I have no piece of a screen on LCD matrix which rendered also with Intel. After I replaced 1366x768 with 1024x768 matrix. It still makes video out for 1366 dots per line. Drivers reports "Error" on EDID Any attempts to change driver were not lucky.

It looks Intel driver ignores modeline at all. And I have no ideas how but setup software controls reals settings of resolution out of options from driver. Which makes them out of its own judgment, sometimes out of EDID sometimes out some macabre witchcraft, but not out of modeline settings.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.