Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was tried to Mount server secondary hard disk shared folder to my client computer. Already the secondary share folder was mound on server like this

/media/sdc1/foldername/

i want to auto mount above share folder to my client computer when start.

The following code was written on /etc/fstab

//192.168.1.150/media/sdc1/HTTPServer     /media/HTTPServer     ntfs-3g     defaults,locale=en_US.utf8   0    0

it's does not work and it's return the following error

mount: only root can mount //192.168.1.150/media/sdc1/HTTPServer on /media/HTTPServer

i was tried to share from ubuntu 12.04 server to ubuntu 13.04 client pc. i was installed samba file share server on server pc. it's work fine for windows os share. but i need ubuntu auto-mount share . i was read so many article for this issues. But i did not get correct please tell anyone. thanks advance

share|improve this question
    
Does Thishelp? –  Mitch Aug 31 '13 at 19:38

1 Answer 1

Looks like that you have tried to mount network share with ntfs filesystem, right? Have you tried to mount it using mount.cifs or smbfs? Or even your share has another filesystem it shoud use smbfs not ntfs-3g I think.

Could you please provide mount -v | grep $foldername output for already mounted share?

And part of samba.conf fot this share from server computer.

share|improve this answer
    
yes i was tried mount.cifs and smbfs also no use. then mount -v | grep $foldername return nothing . –  tamil_arvu Aug 31 '13 at 19:55
    
$foldername means name of your folder under which your share already mounted ($ is a symbol for shell variables). Could you please provide command you used to mount folder directly from cli? –  Svyatoslav Aug 31 '13 at 20:12
    
and could you please provide /etc/samba/smb.conf content. –  Svyatoslav Aug 31 '13 at 20:16
    
hm, I'm just curious - have you used sudo to do mount command? As I see you receive this error from CLI, not from logs. –  Svyatoslav Aug 31 '13 at 20:17
    
No i did not used sudo for mount on etc/fstab –  tamil_arvu Aug 31 '13 at 20:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.