Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install lubuntu (13.04) on legacy notebook (TOSHIBA Satellite 1405-S171, Video Chip = SuperSavage IX/C SDR, 512Mb RAM, Celeron) from CD.

Shortly: GUI install app doesn't work because of video card problem. Fortunately I can press ctrl + alt + F1 and jump to terminal session. How to continue setup from terminal? If I would succeed to install lubuntu I could update video driver later, but now when my system is loaded from CD I do not understand what I could do else... just to continue process from terminal..

Details: boot menu and splash screen works fine but Installer (that one that contains wizard "welcome/language list > choose timezone > choose name") is corrupted: only half of the screen shows something recongnizable, mouse pointer is black square and left "black trace", click doesn't work etc, but keyboard works well so I am able to jump to terminal.

lshw -c video and sudo lspci -k doesn't show the video driver! May be somebody could explain what does it mean?

I have made some experiments with boot string setting vga=XXX and some other boot string options. Splash screen react on them very clearly, but Installer in most cases ignores them. It seems Installer loads another driver. How could I prevent do to it from boot string options? Is it possible to say "use vesa"?

Of course: sudo apt-get install lubuntu-desktop doesn't work as I need, but may be it is possible from terminal a) mount to the notebook's disk b) install lubuntu to this disk and make this disk bootable?

share|improve this question
    
How old is the computer and what type is it? Could you post some more info about the computer itself, as that would help us answer your problem. Another thing, have you tried it with an older version of Ubuntu/Lubuntu, say 12.04 LTS (or even older)? That might work better with your old hardware. –  RPi_Awesomeness Aug 31 '13 at 18:32
    
Notebook description will be added. Unfortunately (or fortunatly) it was my last CD-R so I have no possibilities to experiment with others releases. I hope there are nothing very complex to deal with video driver. All linux enthusiasts should come through it, isn't it? :) –  Roman Pokrovskij Aug 31 '13 at 18:39
    
Do you have a USB pen-drive? You could put the ISO on that and make it a Live-USB. –  RPi_Awesomeness Aug 31 '13 at 18:40
    
This notebook can't be booted from USB. –  Roman Pokrovskij Aug 31 '13 at 18:43

1 Answer 1

up vote 0 down vote accepted

Boot string parameters nomodeset xforcevesa helped me to launch installer without video problems. Installation was completed (one time was aborted by not described "just error during installatio" and restarted by me after successful HDD check, so the reason was left unclear); system was started from HDD without video problems.

although lshw -c video and sudo lspci -k still doesn't show the video driver! What it could be? may be the vesa driver is never shown? may be I do not have important permissions?

P.S. noacpi noapic nolapic also were added to etc/default/grub since system hangs after some period of inactivity

share|improve this answer
    
so problem solved? –  mojo706 Aug 31 '13 at 20:44
    
no... 1) I still do not understand what driver is used, and I want to understand this; 2) installer works but would the system work I do not know (I'm in the installation process right now) –  Roman Pokrovskij Aug 31 '13 at 20:54
    
ok update when you're done –  mojo706 Aug 31 '13 at 20:59
    
system works, but I'm still very interested to know why lshw -c video and sudo lspci -k doesn't bring driver information... –  Roman Pokrovskij Sep 1 '13 at 9:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.