Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

W: Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/raring/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/ferramroberto/java/ubuntu/dists/raring/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

I keep getting this when I download anything from the terminal. How do I get around this?

share|improve this question

marked as duplicate by Jorge Castro, Seth, Kevin Bowen, guntbert, psusi Sep 1 '13 at 23:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
Try running the command sudo apt-get -f update It should try to fix problems. Best of luck! –  RPi_Awesomeness Aug 31 '13 at 17:27
1  
I just tried that and I got the same error. –  Thomas Aug 31 '13 at 17:33

3 Answers 3

Ferramosca Roberto's Java PPA doesn't seem to be up anymore. This is a PPA for Sun/Oracle Java; my guess is that licensing changes preventing up-to-date versions (later than 6u26) from being provided, so after a while he no longer considered it useful to keep up. But that's just a guess.

I recommend removing the PPA; this explains how; this may help too. I'd use ppa-purge for this, since you'll also want to remove the software provided by that PPA (and replace it with something up-to-date); this explains ppa-purge (this simple answer is probably all you need).

Then, if you want to use Oracle's proprietary Java runtime, this explains how. That should achieve what you were using the ppa:ferramroberto/java PPA for before. Or you may prefer to use the OpenJDK (which is also official); for that, this might help.

In short, to remove the broken PPA with ppa-purge and install the latest stable version of Oracle's proprietary JDK, you can run:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ferramroberto/java

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

Source: This answer to that question (for the last three commands).

Unlike some old PPAs, packages from that PPA can provide the latest versions of Oracle Java even with their licensing restrictions prohibiting distribution by unauthorized parties. The way this works is that the packages don't actually contain Oracle Java; instead, they contain scripts that automatically download them from authorized download sites, and install them. Meanwhile the packages manage what version is installed, so it works similarly to the way it would work if the packages did directly provide the software.

Java 8 exists, and you can install it with oracle-java8-installer. But it's still in testing; it's not recommended for general use. Similarly, the old Java 6 still exists, though you should check to see if it still get security updates before using it. To install that, you'd use the oracle-java6-installer package.

share|improve this answer

This error means, that one of the PPAs in your software sources is not accessible. Check if the PPA is still available and if yes update the entry in software source. If not, remove it from your software sources in order to get rid of the error.

Maybe you should also remove all packages from that PPA, since without the PPA they will not be updated. There is a tool called ppa-purge, that will help you to revert anything from a certain PPA to the version from the original Ubuntu repos.

share|improve this answer

This is generally because the PPA does not exist or does not have packages for you Ubuntu version. This could be because that the PPA has become unmaintained or no longer updated. You should try and find a new PPA for the package you want to install. It doesn't stop you from installing other packages which aren't in that PPA however.

You should search the internet for the PPA (which is the first part after lanuchpad.net/ and before /ubuntu), in your case, "ferramroberto/java ppa" . If it's a launchpad PPA, you should find a page with info about all packages and their versions

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.