Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Every time at boot I get a message “Network service discovery disabled. Your current network has a .local domain, which is not recommended and incompatible with the Avahi network service discovery. The service has been disabled.”

Network service discovery disabled

What does this mean for me?

Wi-Fi is disabled.

share|improve this question

4 Answers 4

up vote 19 down vote accepted

It looks like avahi-daemon is started when the network connection is established (/etc/network/if-up.d/avahi-daemon). This notification is informing you that mDNS (Avahi) has been disabled. It's only used for a small number of applications that only work on the local network, it won't adversely affect your internet connection or DNS.

The most well known use for mDNS is sharing music with Rhythmbox (or iTunes) over your LAN. It's an Apple technology, but it's largely been ignored in favour of uPNP or DLNA.

To disable it, you must edit the file /etc/default/avahi-daemon as root:

sudo -i
gedit /etc/default/avahi-daemon

and add this line (or change it if already exists to):

AVAHI_DAEMON_DETECT_LOCAL=0

Source: http://ubuntuforums.org/showthread.php?t=1632952

share|improve this answer
    
And where exactly has been mDNS (Avahi) disabled? On my local network router? I think I don't use it, but I might have used to: I used to run an iTunes service on my FreeNAS server. –  Nickolai Leschov Aug 31 '13 at 15:40
    
@NickolaiLeschov What to do with your network router? It was disabled probably because does nothing to do. When you will run an app that will need it, that app should know how to enable it. –  Radu Rădeanu Aug 31 '13 at 16:15

According to the Avahi wiki there are two workarounds:

Better one:

In /etc/avahi/avahi-daemon.conf uncomment and change the line with domain name to

domain-name=.alocal

Second one:

In /etc/nsswitch.conf delete a [NOTFOUND=return] text.

share|improve this answer
    
Not working for me. –  Vitaly Zdanevich Oct 19 '13 at 9:22
    
Both of them? Are there any changes in the wiki? –  int_ua Oct 20 '13 at 14:48
    
Looks good, please add it as another answer :) –  int_ua Oct 21 '13 at 13:12
    
have not worked for me on ubuntu 14.04 –  decebal May 7 at 7:44

Worked for me (fresh install of Lubuntu 13.10): /etc/default/avahi-daemon must be AVAHI_DAEMON_DETECT_LOCAL=0

share|improve this answer

It probably says that Avahi is disabled because you have a .local domain and Avahi doesn't work very well with this.

Avahi is a zero conf protocol like Apples Bonjour commonly used if you have Macs on your network or if you want to chat with others on your local network without logging in to a server like Google Talk or MSN Messenger.

You can read about the problem here.

You could probably just ignore it or configure your network to use another domain name then the default .local.

share|improve this answer
    
At least here in Finland, the DNS of a major ISP (Sonera) has been configured to claim authority for .local domain. Check host -t soa local. - you should get not found: 3(NXDOMAIN). For example: host -t soa local. 8.8.8.8 will test Google DNS. A broken DNS server will return something like local has SOA record localhost. hostmaster.sonera.fi. 20130911 14400 7200 604800 900. –  Mikko Rantalainen Mar 2 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.