Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I spent an hour trying to remove the recovery mode entry off Grub, but I did not succeed!

I edited the /etc/default/grub and uncommented:

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_LINUX_RECOVERY="true"

and did the update-grub with no success, the entry still exists on reboot.

Also I edit and commented lines regarding the recovery mode in: /boot/grub/grub.cfg

#menuentry 'Ubuntu, with Linux 3.5.0-23-generic (recovery mode)' --class ubuntu --class gnu-linux --class gnu --class os {
#   recordfail
#   insmod gzio
#   insmod part_msdos
#   insmod ext2
#   set root='(hd0,msdos6)'
#   search --no-floppy --fs-uuid --set=root 692988db-a701-4abb-9889-fc61816aa8d8
#   echo    'Loading Linux 3.5.0-23-generic ...'
#   linux   /boot/vmlinuz-3.5.0-23-generic root=UUID=692988db-a701-4abb-9889-fc61816aa8d8 ro recovery nomodeset 
#   echo    'Loading initial ramdisk ...'
#   initrd  /boot/initrd.img-3.5.0-23-generic

then I ran update-grub

I also ran update-grub2

...without success. After restarting, the recovery mode entry still exists. Any ideas?

share|improve this question
add comment

1 Answer 1

Try

#GRUB_DISABLE_RECOVERY="true"

Instead of

GRUB_DISABLE_LINUX_RECOVERY="true"

and running update-grub solved the problem.

share|improve this answer
    
Works! Thanks! :) –  LebLinux Oct 4 '13 at 4:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.