Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've set up a new server running a fresh installation of Ubuntu Server 13.04. I've installed xubuntu-desktop and tightvnc. My ~/.vnc/xstartup configuration file contains the following:

#!/bin/sh

xrdb $HOME/.Xresources
xsetroot -solid grey
#x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
x-window-manager &
# Fix to make GNOME work
export XKL_XMODMAP_DISABLE=1
# /etc/X11/Xsession
startxfce4 &

The VNC server appears to running fine, and I am able to connect to port 5901 successfully using the TightVNC Java client.

My concern is that a lot of icons in the GUI are broken/missing, as shown in this screenshot:

screenshot

Am I missing some commands in my xstartup file?

Ideally, I would like to be able to have the GUI be the default Xubuntu session (with the Xubuntu theme, etc) and not a bare-bones Xfce session.


Update:

For reference, opening the XFCE appearance settings, it shows that the Greybird theme is selected and the icon set is elementary Xfce.

theme icons

share|improve this question
1  
I had a similar issue on a recently rebuilt headless 13.04 box at my work (in particular no icons at all in thunar - but thumbnails OK). I never found a solution, except that it seemed to be something to do with the failure of the xfsettingsd daemon to start (starting it manually caused the icons to flash up briefly, then it immediately died). Maybe this will point you towards a resolution - my pragmatic solution was to switch to an LXDE session. –  steeldriver Aug 31 '13 at 14:02
    
Yeah, from my research, it appears that a lot of people have the same problem with XFCE and VNC across multiple releases of Ubuntu. LXDE sounds like a good idea, but I don't like to give up easily. ;) –  iglvzx Aug 31 '13 at 14:12
    
@steeldriver I have abandoned XFCE and am now using LXDE without any issues. I spent the good part of the day Googling and trying different proposed solutions, but I could not get anything to work for Ubuntu 13.04. –  iglvzx Sep 12 '13 at 17:53
    
Is it possible that you are running Xfce as root (where some other icon theme was chosen) but start xfce4-settings-manager as user? –  landroni Jan 23 at 12:52

2 Answers 2

you properly didn't load vncconfig script for vnc session

add

vncconfig -iconic &

to your xstartup for xubuntu-desktop, your xstartup should look like

#!/bin/sh
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
startxfce4 &

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
share|improve this answer

You can try installing the Greybird theme which is the default theme in Xubuntu with the command:

sudo apt-get install shimmer-themes

Then choosing "greybird-git" (not Greybird!) from the XFCE settings

For the icon theme, use this command:

sudo apt-get install xubuntu-icon-theme

Then choose the "Elementary XFCE Dark" theme (or similar) from the XFCE settings

share|improve this answer
    
This does not help me as the xubuntu-desktop package installed the xubuntu-artwork package, which includes the shimmer-themes and xubuntu-icon-theme packages. –  iglvzx Aug 31 '13 at 13:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.