Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've not long been running Banshee on 11.04, and my main problem with it is that when changing tracks a notification is displayed, this is all fine when using hardware buttons on my laptop to change track, but when using the sound menu the notifications overlap my sound menu.

So I'm just wondering if there is any way to disable notifications from showing, like there is in Rhythmbox?

Thanks,

share|improve this question

3 Answers 3

up vote 9 down vote accepted

Found an almost perfect solution, with thanks to @macydanim to pointing me in the right direction.

In Natty, Banshee won't show up in the notification area, so I ran the following command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'banshee']"

This adds Banshee to a "whitelist" of applications allowed to be shown in the notification area.

Logged out, and logged back in again. Then in Banshee, went to Edit -> Preferences -> Extensions. Disabled Sound Menu Integration and enabled Notification Area Icon. Then, right clicked the notification icon and disabled show notifications.

I then disabled Notification Area Icon extension, and tried re-enabling Sound Menu Integration. This, however, still showed notifications whenever the track was changed. I found out though, that you don't need the Sound Menu Integration plug in enabled for Banshee to work in the sound menu. So if I leave it disabled I don't get notified on track change, but can still operate Banshee from the sound menu. The only downside, is that I can't click the close button on Banshee and have it minimise to tray, so you just have to remember to press the minimise button now instead of the close one and keep Banshee open.

share|improve this answer
    
Thanks, I've been looking for this for some time. Seems to me this could be made easier on the user... –  Shawn Mar 2 '12 at 17:35

After following Josh's instructions I tried just disabling the "Sound Menu Integration" extension (Preferences->Extensions menu) without taking any other action. "Notification Area Icon" is also disabled (by default). That alone seems to disable the notifications.

share|improve this answer

Hey, this is how it worked for me. Maybe its not the obvious way but it worked. In Banshee go to Edit, Preferences,Extensions. In the categorie Utilities there is a checkbox Notification Area Icon, check this. If you now move to the icon in the bar, right click it and uncheck Notifications. You can now also uncheck the box for the Notification Area Icon again, notifications won't pop up again.

share|improve this answer
    
Thanks for the answer, it sounds like it would work but I'm running 11.04 and there isn't a notification area anymore. –  Josh Apr 13 '11 at 16:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.