Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've almost got this problem solved... I've got both displays working now. The secondary display is displaying a purple background. Unfortunately, I can't use it. (I can't move the mouse into it, etc.)

Here is the output of xrandr --verbose --screen 1:


Screen 1: minimum 320 x 200, current 800 x 480, maximum 800 x 480
LILLIPUT USB Mo connected (normal)
 Identifier: 0x175
 Timestamp:  271103
 Subpixel:   horizontal rgb
 Clones:    
 CRTC:       0
 CRTCs:      0
 Transform:  1.000000 0.000000 0.000000
             0.000000 1.000000 0.000000
             0.000000 0.000000 1.000000
            filter: 
 EDID:
  00ffffffffffff0031900120eb030000
  2013010380101778ca54548f54599726
  cb545400000001010101010101010101
  010101010101540b208030e02d102830
  7304000000000018000000fd00374118
  2905000a202020202020000000fc0055
  5342204d6f6e69746f720a0a00000010
  00000000000000000000000000000028
  800x480 (0x176)   29.0MHz -HSync -VSync +preferred
        h: width   800 start  840 end  888 total  928 skew    0 clock   31.2KHz
        v: height  480 start  503 end  506 total  525           clock   59.5Hz

And here is my xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@yellow)  Fri Apr  9 11:51:21 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Fri Mar 12 02:12:40 PST 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      1  "DisplayLinkScreen" RightOf "Screen0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LPL"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400M GS"
    BusID          "PCI:1:0:0"
    Screen          0
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

#################################################

############### DisplayLink Stuff ###############

Section "Device"
    Identifier      "DisplayLinkDevice"
    driver          "displaylink"
    Option  "fbdev" "/dev/fb0"
EndSection

Section "Monitor"
    Identifier      "DisplayLinkMonitor"
EndSection

Section "Screen"
    Identifier      "DisplayLinkScreen"
    Device          "DisplayLinkDevice"
    Monitor         "DisplayLinkMonitor"
    DefaultDepth    16
    SubSection "Display"
        Depth   16
        Modes   "800×480"
    EndSubSection
EndSection

Update: After adding...

Xinerama "1"

...I now have the secondary screen mirroring the primary one. But I'm hoping I can have separate displays.

share|improve this question

1 Answer 1

up vote 4 down vote accepted

I fixed it. The problem is that in order to use Xinerama, both displays must be using the same bit depth. (16 bits)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.