Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't seem to get any updates installed. I keep getting the following errors. How do I solve this?

Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  linux-headers-3.2.0-44-generic linux-headers-3.2.0-44
  linux-image-3.2.0-44-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  linux-server
The following packages will be upgraded:
  linux-server
1 upgraded, 0 newly installed, 0 to remove and 117 not upgraded.
1 not fully installed or removed.
Need to get 0 B/1,734 B of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? dpkg: dependency problems prevent configuration of linux-server:
 linux-server depends on linux-image-server (= 3.2.0.45.54); however:
  Version of linux-image-server on system is 3.2.0.52.62.
 linux-server depends on linux-headers-server (= 3.2.0.45.54); however:
  Version of linux-headers-server on system is 3.2.0.52.62.
dpkg: error processing linux-server (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 linux-server
share|improve this question

2 Answers 2

I think you can try apt-get -f install linux-server.

share|improve this answer

You've provided us with output but have not told us exactly what you are doing that produces it, so any answer to this question will probably be speculative in nature. However, feel free to edit your question to provide more information.

One common cause of this sort of problem is if you are attempting to upgrade or install software from the Terminal with apt-get or aptitude, without first running sudo apt-get update (or sudo aptitude update).

So, if you're running upgrade, dist-upgrade, or install commands from the Terminal without first running an update command, then you should do that.

sudo apt-get update

The error message is saying that a package cannot be installed because it depends on an older version of a package than is available. Running sudo apt-get update (or sudo aptitude update) updates information on your computer about what packages are available in what versions from where, and what packages/versions they depend on.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.