Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running 12.04 on my MacBook Pro 5,5, and my Wi-Fi is working fine, but I'm having problems getting it to scan automatically at startup time.

On first login I get a notification that I'm disconnected, and no networks are listed in the Network Manager tray widget, even though Enable Wireless is ticked.

If I go to the terminal and do a manual scan, Network Manager kicks in after a second or two, populates the list and connects automatically to a saved network if available.

$ sudo iwlist wlan0 s

I've run the following commands immediately after startup for diagnosing the situation

$ iwconfig
$ sudo lshw -C network
$ sudo lspci -nn | grep 0280

(output here)

I'm not an expert, but as far as I can tell the driver is loaded and everything is working, but Network Manager just doesn't start a scan without a kick in the behind. I've spent a lot of time searching around, but I can't seem to find anyone with the same issue. Anyone know how I can resolve this? Thanks in advance.

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

As I suspected, this was probably a problem with Network Manager, and not driver related. I installed Wicd as a workaround and removed Network Manager, and now everything is working perfectly.

If I try to reinstall Network Manager and remove wicd again, I will post the results here, in case the problem was a corrupt config file or something similar.

share|improve this answer
add comment

From ubuntuforums, this is related to a bug on Network-Manager, valid workaround in here:

Change the last part in /usr/lib/pm-utils/sleep.d/55NetworkManager

from
  thaw|resume)
    resume_nm

to
  thaw|resume)
  resume_nm
  sleep 2 && iwlist eth1 scanning &

This will force a network rescan on every resume.

Kudos to mu3en from https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/274405/comments/74

share|improve this answer
add comment

Open your terminal and type as

sudo nano /etc/modprobe.d/iwlwifi.conf

It will open a text editor and then

paste these lines

options iwlwifi bt_coex_active=0
options iwlwifi 11n_disable=1

Then restart your system to apply the changes. From now on wards even you have suspended your system , after wake up it will again reconnect.

Credit: Ubuntuforums

Note: make sure that you dont have too many saved connections.

share|improve this answer
    
Thank you for the answer, but unfortunately this had no effect. –  Henrik Sep 6 '13 at 22:26
    
look at the Forums link in my answer. its a years research thread. –  raaz Sep 7 '13 at 0:12
    
I'm sorry, but this was a dead end. –  Henrik Sep 7 '13 at 6:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.