Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What is the easiest way to install PySide in Ubuntu 13.04? There is a link to a PPA in their binary packages section but it does not have packages for Raring.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I've only just noticed that there's a raft of python-pyside packages in the repos. Currently version 1.1.2 (the same as their latest PPA version for Precise).

$ apt-cache search ^python3?-pyside
python-pyside - Python bindings for Qt4 (big metapackage)
python-pyside.phonon - Qt 4 Phonon module - Python bindings
python-pyside.qtcore - Qt 4 core module - Python bindings
python-pyside.qtdeclarative - Qt 4 Declarative module - Python bindings
python-pyside.qtgui - Qt 4 GUI module - Python bindings
python-pyside.qthelp - Qt 4 help module - Python bindings
python-pyside.qtnetwork - Qt 4 network module - Python bindings
python-pyside.qtopengl - Qt 4 OpenGL module - Python bindings
python-pyside.qtscript - Qt 4 script module - Python bindings
python-pyside.qtsql - Qt 4 SQL module - Python bindings
python-pyside.qtsvg - Qt 4 SVG module - Python bindings
python-pyside.qttest - Qt 4 test module - Python bindings
python-pyside.qtuitools - Qt 4 UI tools module - Python bindings
python-pyside.qtwebkit - Qt 4 WebKit module - Python bindings
python-pyside.qtxml - Qt 4 XML module - Python bindings
python3-pyside - Python3 bindings for Qt4 (big metapackage)
python3-pyside.phonon - Qt 4 Phonon module - Python3 bindings
python3-pyside.qtcore - Qt 4 core module - Python3 bindings
python3-pyside.qtdeclarative - Qt 4 Declarative module - Python3 bindings
python3-pyside.qtgui - Qt 4 GUI module - Python3 bindings
python3-pyside.qthelp - Qt 4 help module - Python3 bindings
python3-pyside.qtnetwork - Qt 4 network module - Python3 bindings
python3-pyside.qtopengl - Qt 4 OpenGL module - Python3 bindings
python3-pyside.qtscript - Qt 4 script module - Python3 bindings
python3-pyside.qtsql - Qt 4 SQL module - Python3 bindings
python3-pyside.qtsvg - Qt 4 SVG module - Python3 bindings
python3-pyside.qttest - Qt 4 test module - Python3 bindings
python3-pyside.qtuitools - Qt 4 UI tools module - Python3 bindings
python3-pyside.qtwebkit - Qt 4 WebKit module - Python3 bindings
python3-pyside.qtxml - Qt 4 XML module - Python3 bindings

Regarding the installation issues, if you have extra repositories installed, they may be borking up the process. Make sure your apt-cache policy python-pyside looks vaguely like the following:

python-pyside:
  Installed: (none)
  Candidate: 1.1.2-1ubuntu1
  Version table:
     1.1.2-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/universe amd64 Packages

If you have extra sources and they're providing the candidate and they don't work, that'll break installation.

share|improve this answer
    
It says Package python-pyside is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'python-pyside' has no installation candidate –  Archisman Panigrahi Aug 30 '13 at 9:47
    
That isn't what it says here. I've added an edit about sources. –  Oli Aug 30 '13 at 9:56
    
For me it looks like this python-pyside: Installed: (none) Candidate: (none) Version table: So, what should I do now? I have removed the PPA. –  Archisman Panigrahi Aug 30 '13 at 10:13
    
@apandada1 That suggests you don't have the universe repository enabled. Fix that here. –  Oli Aug 30 '13 at 13:17
    
♦ I do have universe enabled. –  Archisman Panigrahi Aug 31 '13 at 8:16
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.