Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I own a Dell Vostro 3550 laptop which uses both Windows 7 and Ubuntu. The laptop broke a month ago and I called Dell support to fix it. A small metallic clip was dislodged from the back lid and short-circuited "something" on the motherboard. I wasn't present during repair so I do not know exactly what was roasted.

After repair everything works fine on Windows 7 but on Ubuntu the mouse cursor and the windows environment are flickering. Sometimes it stops for an hour or so but it reoccurs.

I've tried a fresh install of Ubuntu along with Fedora and Funduntu but flickering is still present. My intuition says that its a hardware issue since I've never had flickering problems in Ubuntu(currently run the 12.04 vostro 3550 distro), although I kind of spended a lot of time in order to setup Vostro 3550 graphics to work properly.

I want to investigate more before calling Dell support again because Windows 7 works flawlessly and it might be a drivers problem(although I've tried almost everything regarding ati drivers for ubuntu, disabled discrete card, disable integrated card etc.)

The graphics card are AMD Radeon 6630M and Intel HD 3000.

Any ideas on how to fix that problem?

share|improve this question

marked as duplicate by Braiam, Eliah Kagan, Oli Sep 2 '13 at 11:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

Unfortunately this sounds a lot like a hardware issue to me.

One thing you might want to try is adjusting your OS's monitor/display settings, on the off-chance that it has selected a default resolution or refresh rate that is not compatible with the display.

share|improve this answer
    
What is your guess about the fact that on Windows 7 it works fine but on Ubuntu flickering exists? –  Jahn EstaCado Aug 30 '13 at 11:42
    
I've tried this solution askubuntu.com/a/155351/187872 and it seems that it works for now. Also the dual monitor display work fine now. Only once when I booted from Ubuntu the login screen couldnt be displayed and I had to log in through command line and reboot. I will use current setup for some weeks and if the problem is solver i will mark the thread as "solved"! –  Jahn EstaCado Aug 30 '13 at 13:43
    
Well the aforementioned solution doesn't work at all. Don't know why after I first tried it the flickering stopped but now it is still present and more intense. If its a hardeare issue it's is kind of weird that on Windows 7 everything works fine.. –  Jahn EstaCado Sep 2 '13 at 10:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.