Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I restore my system from sleep in Ubuntu 13.04, my Audigy2 ZS soundcard won't play sound. Sound after restore from sleep used to work with previous versions of Ubuntu, as I recall. The soundcard does show up in the Sound Settings dialog immediately after restore, but trying to play sound jams (e.g., Banshee's playback bar won't move). I have tried this:

pulseaudio -k
sudo alsa force-reload
pulseaudio -D

The soundcard doesn't show up in Sound Settings after that. Naturally, that's not the goal, however.

My problem is similar to this bug from 2008: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/222428

Here's some of the output of a bunch of diagnostics. I'm sorry if it's too much — I don't really know what's relevant.

/var/log/syslog:

I've omitted lines containing snd-emu10k1: Suspected sound card removal, as there were 8934 of them at last count. The full omitted lines seem to read, for example, Aug 29 18:37:51 andrew-desktop kernel: [12747.531101] snd-emu10k1: Suspected sound card removal. Also, all lines shown here seem to occur after the resume.

/var/log$ cat syslog | grep -v "snd-emu10k1: Suspected sound card removal" | grep "emu"
Aug 29 17:57:33 andrew-desktop kernel: [10325.449713] snd_emu10k1 0000:04:00.0: Refused to change power state, currently in D3
Aug 29 17:57:33 andrew-desktop kernel: [10325.821399] snd_emu10k1 0000:04:00.0: enabling device (0000 -> 0001)
Aug 29 17:57:33 andrew-desktop kernel: [10325.821415] snd_emu10k1 0000:04:00.0: setting latency timer to 64
Aug 29 20:06:51 andrew-desktop kernel: [18082.497858] snd_emu10k1: probe of 0000:04:00.0 failed with error -5
Aug 29 20:07:39 andrew-desktop kernel: [18130.563035] snd_emu10k1: probe of 0000:04:00.0 failed with error -5
Aug 29 20:07:50 andrew-desktop kernel: [18140.992866] snd_emu10k1: probe of 0000:04:00.0 failed with error -5

uname -r:

$ uname -r
3.8.0-29-generic

aplay -l:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC889 Analog [ALC889 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC889 Digital [ALC889 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 11: HDMI 5 [HDMI 5]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

lspci -v:

Snipped for relevance.

04:00.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
    Subsystem: Creative Labs SB Audigy 2 ZS (SB0350)
    Flags: medium devsel, IRQ 19
    I/O ports at ef80 [size=64]
    Capabilities: <access denied>

04:00.1 Input device controller: Creative Labs SB Audigy Game Port (rev 04)
    Subsystem: Creative Labs SB Audigy Game Port
    Flags: medium devsel
    I/O ports at eff8 [size=8]
    Capabilities: <access denied>
    Kernel driver in use: Emu10k1_gameport

04:00.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04) (prog-if 10 [OHCI])
    Subsystem: Creative Labs SB Audigy FireWire Port
    Flags: medium devsel, IRQ 16
    [virtual] Memory at fb9ff000 (32-bit, non-prefetchable) [size=2K]
    [virtual] Memory at fb9f8000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: firewire_ohci

modprobe snd-emu10k1:

(no output)

andrew@andrew-desktop:/var/log$ sudo modprobe snd-emu10k1
[sudo] password for andrew:

cat /proc/asound/cards:

$ cat /proc/asound/cards 0 [PCH ]: HDA-Intel - HDA Intel PCH HDA Intel PCH at 0xfbff8000 irq 46 1 [HDMI ]: HDA-Intel - HDA ATI HDMI HDA ATI HDMI at 0xfbafc000 irq 47

uname -a

$ uname -a
Linux andrew-desktop 3.8.0-29-generic #42-Ubuntu SMP Tue Aug 13 19:40:39 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
1  
Refused to change power state means that switching the power back to on did not work. Report this bug in the Ubuntu bug tracker. –  CL. Aug 30 '13 at 6:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.