Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Ubuntu Studio 13.04 on a Thinkpad T420s. I haven't customised the mute/volume scripts etc. The mute key mutes my audio but doesn't unmute it. When I run alsamixer I see the effect of the mute key on alsa: it mutes both the "Master" and the "Headphone"/"Speaker" channels, but then on un-mute it only un-mutes the "Master" channel.

I can manually un-mute the component channels in alsamixer, and my sound comes back. But of course I shouldn't have to.

How do I fix it so that mute-unmute works via the key?

(My problem seems similar to question 118675 but not the same, and the accepted answer there doesn't affect my situation.)

(I was using older Ubuntu Studio 11.10 until recent upgrade, and the mute key was configured fine.)

share|improve this question
    
I think this bug might be what's going on, and this particular explanatory comment: bug 878986 comment 29 - commenter says "by controlling PulseAudio instead of amixer, your keyboard shortcuts will work correctly" - how? –  danstowell Aug 30 '13 at 6:41

2 Answers 2

Thanks so much! This helped me with my Arch/LXDE setup - the mute button xml that is recommended on the LXDE wiki mutes all of the channels in alsamixer and doesn't unmute them (at least not for my sound card).

How I got it fixed:

I changed the XF86AudioMute command value to:

amixer -q -D pulse sset Master toggle
share|improve this answer
    
Welcome to Ask Ubuntu. You can mark the answer which worked for you as accepted.. –  rusty Jan 26 at 16:37

OK I believe I have solved it: the important thing to know is I'm using Ubuntu Studio, which means the window manager is openbox. So what I need to do is edit the keybindings defined in ~/.config/openbox/lxde-rc.xml - you can see the option defined here:

  <keybind key="XF86AudioMute">       <action name="Execute">        <command>amixer -q sset Master toggle</command>     </action>   </keybind>

which I edit to become:

<keybind key="XF86AudioMute"> <action name="Execute"> <command>amixer -q -D pulse sset Master toggle</command> </action> </keybind>

and then after logout-login, the mute key works as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.