Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am hoping someone in here can help me. I am new to Linux and Ubuntu. But I have to say I really love using the Os. I am running Ubuntu 12.04 along side Windowns 7. Both Os are running perfect bar the wireless on Ubuntu, just not working. Network cable is fine.

My System details are Acer Aspire 5103 WLMI, AMD Turion 64x2, 120G HD, upgraded to 4G Ram with Ubuntu running along side Windows 7. Network controller is working fine, with perfect WiFi on the Windows 7 partition. But I have tried everything to get the WiFi to work on Ubuntu with no luck so far.

Below is the Network controller details.

Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02).

I have tried everything on the How to Install Broadcom Wireless Drivers reless-drivers page. With no joy. I have been at this three days now. All help and advice welcome! Even if it doesnt work. TRIAL and ERROR can be a great way to learn.

Regards Sean

share|improve this question
Possible duplicate of Installing Broadcom Wireless Drivers – Pilot6 Oct 22 '15 at 15:57


sudo apt-get purge bcmwl-kernel-source

sudo apt-get install linux-firmware-nonfree

sudo modprobe b43
share|improve this answer
This is outdated. linux-firmware-nonfree is obsolete. – Pilot6 Jun 7 '15 at 10:30

Driver for this adapter can be installed by

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer
sudo modprobe -r brcmsmac bcma
sudo modprobe b43

You have to be connected to internet by wire to install the driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.