Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am working with an Ubuntu 10.04 VM. By default, vim shows syntax color and I don't want it. I do not have a .vimrc file in my home directory (or anywhere in the system for that matter). I do have a file called .viminfo in my home directory but that doesn't seem to be where the setting is because when I rename it, the syntax color is still on. I also like to have line numbers and for that I created a .exrc file in my home.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

To turn off color syntax highlighting, pres ESC and type:

:syntax off

To turn it on again, type:

:syntax on

To make the changes permanently, you can create ~/.vimrc file and add the following line:

syntax off
share|improve this answer
    
but that is just for in the existing instance. putting it in .exrc makes it cross instance –  amphibient Aug 29 '13 at 21:26
1  
@amphibient I just edited my answer. –  Radu Rădeanu Aug 29 '13 at 21:27

Got it figured:

syntax off

in .vimrc

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.