Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed ubuntu 13.04 in EFI mode on my dell inspiron 15z successfully. When I boot my laptop in UEFI mode with secure boot off, I get blank ubuntu screen- I got no activity on hard disk LED indicator. The ubuntu is not booted. But if I change boot mode from UEFI to legacy, Ubuntu works fine. Infact, right now I am writing this post from ubuntu. Also windows 8 is not in grub menu. Can somebody tell me how can I add windows 8 on grub menu and how can I boot installed ubuntu in EFI mode? I've tried to use boot-repair before, but it didn't go well. Here's the boot info file. Thanks http://paste.ubuntu.com/6041499/

share|improve this question

1 Answer 1

Your Boot Info Script output is a bit puzzling: It shows a GUID Partition Table (GPT) disk, which means that Windows will boot only in EFI mode. There's also evidence of an EFI-mode Windows boot loader. So far so good. It gets puzzling in that there's no evidence of GRUB on the hard disk, either in EFI mode or in BIOS mode; but there is evidence of a BIOS-mode Windows boot loader. My suspicion is that the Boot Info Script has simply mis-identified the BIOS-mode GRUB as the Windows boot loader. Certainly that's the simplest explanation that also explains why you can boot both Windows and Linux; however, it could be that something else is going on.

If I'm right and you've got a BIOS-mode GRUB, then you'll never get it to chainload to your EFI-mode Windows; that's just not possible. You could, though, use my rEFInd boot manager to switch between EFI-mode Windows and BIOS-mode Linux. You'd need to:

  1. Install rEFInd in Windows, as described in the documentation.
  2. Edit the refind.conf file: Uncomment the scanfor line and ensure that hdbios is among the options.

The result should be that rEFInd will enable you to boot to Windows or to GRUB, and GRUB will then boot Linux. You could also try an EFI-mode boot of Linux by installing an EFI filesystem driver for your Linux filesystem (probably ext4fs). Given what you've reported, this might not work now, but it might work in the future, once drivers and default configurations mature for better EFI support.

Keep in mind, though, that I'm very uncertain about any of this; it could be that you're actually booting Linux in EFI mode. If so, a tweak to GRUB's configuration might work, or installing rEFInd and its ext4fs driver would also work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.