Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There are two errors in the locale settings for en-CA.

The first is paper. Although we use metric for just about everything (distance, temperature, and measurements), we use American paper sizes (8-1/2 x 11, 11 x 14, and 11 x 17). By default, the locale settings in Linux for en-CA assume metric paper, so that every individual program needs to have the default paper sizes manually adjusted. This is annoying.

The second is currency format, which is currently set as $20457.99. The correct format is $20,457.99.

I haven't tested fr-CA, but I am suspecting similar issues. They also use American paper size by default and their currency format is 20 457,99$.

Two questions: 1. How can I change these two items on my installation? I have Ubuntu 12.04 Desktop AMD64 installed. 2. How do I go about proposing a change so that this can be incorporated into the core Linux product? I'm just an end-user, but this might be a small contribution.

Thanks,

Language Settings English (Canada) en-CA

share|improve this question
add comment

2 Answers 2

As regards paper size, it's correct in the English-Canadian locale already. However, in Ubuntu 12.04 that setting is not always effective (the problem has been fixed in 13.04). To fix it on your installation you can run the command

sudo paperconfig -p letter

To change the currency format on your system, you may want to edit the locale specification file as suggested by @Jean-Marie.

If you are sure about the currency format, please file a bug at http://sourceware.org/bugzilla/enter_bug.cgi?product=glibc However, they won't likely change it just because you ask them... You need to point at authoritative sources to convince them that you are right and the current locale specification wrong. ;-)

share|improve this answer
    
Bug filed, thanks for the heads up. By the way, the e-mail address that I found in the source file turned out to be not valid. –  user94943 Sep 3 '13 at 2:09
    
@user94943: As I said, it's already correct in the locale, so sourceware.org/bugzilla/show_bug.cgi?id=15925 is pointless. Your bug should better have been about the currency format. As regards paper size, did you try the command I suggested? –  Gunnar Hjalmarsson Sep 4 '13 at 18:05
    
I did try the paper size command and it appears to have solved that problem. I am not sure where I can test the currency - Calc seems to be handling that correctly. The reason for that question is when I setup the Language - the number format appears correct, but the currency format is missing the separator (comma). –  user94943 Sep 4 '13 at 22:12
    
@user94943: The example currency format in Language Support reflects the currency format of the current locale. I see no reason for further testing. –  Gunnar Hjalmarsson Sep 5 '13 at 19:09
add comment

1- You can change your locale settings by editing /usr/share/i18n/locales/en_CA and then applying the changes:

gksudo gedit /usr/share/i18n/locales/en_CA
sudo locale-gen en_CA.utf8

2- You might find contact information in the file.

share|improve this answer
    
I found the contact information in the file, so I'll send that person an e-mail. Thanks! –  user94943 Sep 3 '13 at 0:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.